View Full Version : How to allow plugins to write stuff to Program Files folders?

11-28-2012, 04:00 AM
I am using the 32bit version Layout at the moment because I'm needing to use a particular plugin that is not yet 64bit (nor probably ever will be - it is an export plugin that is probably abandoned).

Anyway. In this latest install of LW (11.03 if that matters) - I've (as usual) set up my MyPlugins folder in my Program Files (x86)\Newtek\Lightwave folder and have subfolders in there for Layout and Modeler. Normally I copy or install my purchased or free plugins into there so that I can at a glance tell the difference between what is installed with LW and what I've added.

Well this particular plugin that I'm using creates its own config *.cfg file where it saves its settings inside the same folder that it was installed in (i.e. added as a Plugin from). When I last used this plugin some time ago it was when I was using LW 9.6x and it seemed to work fine. In LW 11.x it fails because it can't write its settings - and in 9.6 (which I no longer have installed) it would be able to write into Program Files (x86) but in LW 11 it cannot. This plugin does work when I add it from an external folder like my Desktop but just not when it is added from my Program Files (x86)\Newtek\Lightwave\MyPlugins\Layout folder. So I tried various ways of trying to change permissions on the MyPlugins (and subfolders) and that didn't seem to work, nor did running Layout as an Administrator.

I realize that the Program Files (x86) is a somewhat "protected" folder - but I can't figure out why 9.6 worked (in same Win 7 x64 OS) and LW 11 won't? How do you guys set up your plugin folders to work if they need to write temp files and are nested inside Program Files?

thanks for any ideas as I'd prefer to keep all my custom installed plugins together nested in my MyPlugins folder.

11-28-2012, 02:19 PM
I do the same, only I put my plugins in a folder called 3rdParty inside the regular LightWave/Support/Plugins folder with no problem. Mind you, I don't use Program Files either and have never done. C:\NewTek all the way for me.


11-29-2012, 02:55 AM
Yup I used to too, but LW11 default install path is in the Program Files folder.

11-29-2012, 03:55 AM
Sure, but then it always was I think. I just take out the "\Program Files" bit from the path :)


11-29-2012, 07:06 AM
Have you tried running LW as administrator?

You can either right-click and run as admin... OR

If you right-click on the shortcut, choose properties, and then 'advanced'... tick run as administrator... and try the plugin again! :D


Sorry, didn't read the bit where you'd tried that! Sorryyyyyyy! :D