PDA

View Full Version : Material Node editor issue



jutland
11-27-2012, 02:53 PM
A moment of your time please,

Trying out the Fast skin material in the node editor. While it gives good results. Somethng appears to be wrong. You can see the wireframe of the model through the material. Also not sure how to get rid of the fuzziness of the material. Used the default settings on the Fast Skin node. So i am at a lose for why the wireframe is showing.

Included a render of the issue and a screenshot of the node editor settings.

Please point out the errors of my ways :)

P.S. Sorry for the 'nudeness' of the char.

stiff paper
11-27-2012, 03:38 PM
Could it be something as straightforward as not having smoothing turned on?

jutland
11-27-2012, 03:52 PM
Have checked that smoothing is turned on for all involved surfaces. The wireframe is showing more polygons that then the subpatched model. Thanks to Lightwave subdividing and tripling the mesh.

MarcusM
11-27-2012, 05:13 PM
I confirm this issue. With simple ball model and fast skin, in VPR and render are visible edges (LW 10.1)

lertola2
11-27-2012, 07:02 PM
Do you have subdivision order set to first? If so try setting it to last.

jutland
11-27-2012, 09:43 PM
Do you have subdivision order set to first? If so try setting it to last.

Thought of that and set it to last, same results. Only brighter.

jutland
11-27-2012, 09:43 PM
oops double post ...

OFF
11-27-2012, 10:03 PM
SSS material is almost never used by itself, in its pure form, but, as a rule, in combination with the tools governing its input parameters.
I recommend you to search the forums for skin and SSS tags - you'll find plenty of examples of different types of construction methods shaders.

RebelHill
11-28-2012, 04:12 AM
YEah... this should be fine, most likely just something silly on, or off, which shouldnt be. Easiest is to post an example, just a ball or soemthing that demonstrates the prob.

jutland
11-28-2012, 01:14 PM
Tried the the Simple Skin node on a simple globe. Using the default texture in LW. Used the default settings in Simple skin. The only thing change is the color (245,204,187). All that was done is connecting the material ouput to the material input of the texture in the node editor.

Included a render of the default surface and the Simple Skin render. The wireframe on the Simple skin still shows through on its render. Something tells me that this isn't the result desired.

While I agree that Simple Skin shouldn't be used by itself. As in the case of UV mapping. The wireframe of the mesh should not show through the base texturing of the model.

This was rendered in LW 10.1

Have discovered that when I freeze the globe's mesh. The framewire disappears. Believe that the shader results depends on the resolution of the mesh. This makes me beleive that the shader results depends on the resolution of the mesh. Please correct me if I am wrong on this assumption.

chikega
04-21-2013, 12:20 PM
This makes me beleive that the shader results depends on the resolution of the mesh. Please correct me if I am wrong on this assumption.

Hi jutland, I'm not sure if you've found a solution to this issue or not. I was able to reproduce similar results as you've shown. But I had to decrease the "Render Subpatch" level under "Object Properties">"Geometry" to "1" for the wire mesh to show through. At it's default of "3" for "Per Object Level", I saw no evidence of show through. I can definitely see faceting in the last image you posted. So, you may want to double check your "Render SubPatch" settings. :)