PDA

View Full Version : instance shadows



OFF
11-27-2012, 01:58 AM
I'm working on a scene where there are trees and the bushes - which are planted as instances. The problem is that the shadow of these instances are cast on other objects / surfaces scenes turn into bunches of black beads (as in the pictures). This happens only on those surfaces that are assigned shader Ambient occlusive. AO shader was used native built, from DP_KIT, SG_Ambient_Occlusion - the result is the same. This is a consequence of the limitations in what instances?

109399

109400

Sensei
11-27-2012, 02:50 AM
Are you using Ambient Occlusion with or without interpolation cache?

Occlusion I node has no interpolation.
Occlusion II node has interpolation turned on by default.
DPKit - I have no idea, never used.

If you're using with interpolation, try turning it off.

You can try baking occlusion to image map, then use 2D Textures > Image node instead of real-time calculations (if you're using occlusion just to have nicer leafs).

OFF
11-27-2012, 04:59 AM
Thank Sensei! I tried different versions of ambient shader with different types of interpolation as in the shader, and in setting of global illumination.
The result is - a lot of noise and black spots. This is very strange...
Noninterpolate Radiosity and noninterpolate AO_shader:
109402

Sensei
11-27-2012, 05:44 AM
In normal circumstances AO nodes have non impact on shadows.. Normal usage is simply plugging them to Diffuse scalar. AO could have impact on shadows only if it's plugged to Transparency. Because shadow calculating routine is checking whether surface is transparent or opaque.

So where are you plugging them?
Show screen-shot of Node Editor..

It would be better if you would attach scene..

OFF
11-27-2012, 05:59 AM
Yes, I'll try to do a little scene based on project objects.
Here shader options for the ground surface:
109403

dpont
11-27-2012, 06:17 AM
In LW11 sp3 and native AO shader,
number of samples is defined in the Render Settings panel,
default is 8, which is quite low but
softness is achieved by Adaptive Sampling,
increase the max number of AA passes, here 36,

109404
Right, reference object,
Left, an Instance.

Denis.

OFF
11-27-2012, 07:15 AM
Thank you all for your answers, but the problem is, oddly enough, was in the clip map (bug?):
Without Clip map:
109405
With Clip map:
109406

mummyman
11-27-2012, 08:16 AM
Wow...clip map! I would never think of checking that. Have to remember that one... Glad you figured it out.

OFF
11-27-2012, 08:50 PM
Problem, as I understand it, not in the Clip map's - problem in the errors in the UV technique in this tree's. With a normal, clean UV map this does not occur when rendering instances or single mesh.