View Full Version : Scene flicker and cache problems

11-22-2012, 02:56 AM
Hey all,

I'm trying to get this animation to render without flicker. Seem like no matter if I turn on normal or animated cache there's issues. It also takes maybe about 30 seconds to start rendering once it sees the radiosity is computed. Can someone take a look and see if I'm doing something wrong? Thanks!

11-22-2012, 03:24 AM
Moving objects, taht's your problem. Caching is only good for animated camera moves, not object or lights. Your best bet is to turn off cache and use much higher rpe.... try starting at 600/600.

11-22-2012, 03:27 AM
Or simply use not interpolated GI..

11-22-2012, 05:14 AM
I've fiddled around with a Cornell box, all sorts of things, many MB passes. In the end as said above. It's easier just to turn off GI. The one benefit you will get is an underlying quality that just isn't quite there in a GI render.

11-23-2012, 01:42 PM
I've fiddled around with a Cornell box, all sorts of things, many MB passes. In the end as said above.
Yep, you'll save yourself a lot of pain by just switching to brute-force MC (and/or try fPrime if you have it avail). LW interp GI just isn't worth the fight in such scenarios (moving obj and/or lights), IME. You *might* be able to get something passable with enough experimentation, but also might not, and regardless it'll be pain all the way.

11-24-2012, 05:10 AM
Yep, you'll save yourself a lot of pain by just switching to brute-force MC (and/or try fPrime if you have it avail). LW interp GI just isn't worth the fight in such scenarios (moving obj and/or lights), IME. You *might* be able to get something passable with enough experimentation, but also might not, and regardless it'll be pain all the way.

Not at all... brute force is quite unnecessary. As you add more and more and more rpe to, and tweak max pixel spacing of an iterpolated solution, you effectively approach a brute force outcome. And you can turn things up quite high, giving clean renders but still much quicker than you get without interoplation. The central "trick" is to keep your primary and secondary rays reasonably balanced, and at high vals... Id reckon for this scene 600-1000 would do it, but would still be much faster than brute force.

11-24-2012, 07:58 AM
Hey all. I ended up just turning off GI and putting several lights in. The only problem is, now I can't get shadows inside the box. Looks like there's maybe too much light everywhere? But even when the box is closed there's still light? I do have ambient light set to about 40. Should I just switch back to GI without cache and just more rays? I think before it was taking like 7-8 min per frame.. I tried to cheat shadows with dpkit's shadow node.. but that wasn't working :S

11-24-2012, 08:10 AM
How about adding little occlusion shader? ;)

Plug it to gradient, if you don't want to have it too extreme.

11-24-2012, 08:16 AM
I tried all the occlusion shaders haha.. I'll try gradient though.. occlusion was the most promising result but looked too grainy So.. should it be occlusion II > gradient > diffuse?

11-24-2012, 08:21 AM
You can also paint weight map, and use it to drive gradient key (click Show Output) - and make one area darker, than other.

You can paint 2nd weight map and plug it to occlusion node distance (Max input, so it's not infinite but driven by weight map).

11-24-2012, 08:30 AM
I'm animating an opening box though.. isn't that going to look like it's always dark in the box even when it opens?

11-24-2012, 08:34 AM
Then add Const > Scalar and envelope it... and decrease occlusion effect using this scalar in animation.

11-24-2012, 08:53 AM
I'm pretty sure I'm doing a lot wrong here haha

11-24-2012, 08:56 AM
Totally wrong.. ;)

Occlusion node output plug to Gradient Input (not Bg Color) in the first place..
The main difference between Occlusion II and Occlusion is that II has interpolation cache, I is pure brute force.

0.0 black in occlusion, remap using Gradient to something higher (in other words - make it brighter).
1.0 white in occlusion, should not be changed.

And of course don't plug to Diffuse Shading - because it replaced regular shading. But I guess you were just testing.

11-24-2012, 09:12 AM
Alright. I'm not quite sure I got this right. This is what I understood though.
So... should I be using occ I or II?
And the gradient goes into diffuse instead of diffuse shading?

11-24-2012, 09:26 AM
Are you using Occlusion Mode Infinite?

Range is the most important thing in Occlusion.

11-24-2012, 09:32 AM
ahh yes :) I have it set to ranged 100 mm now. It shows up better in VPR than the actual render though :S

11-24-2012, 09:40 AM
Here are mine tests..
I prefer working globally - the all materials at once..

See how it looks like.

Normal shading:

Just occlusion (extreme):

Occlusion and normal shading together: (I should plug to Diffuse not to Color, don't make this mistake)

Here is with gradient to decrease occlusion effect a bit:

And another frame:

11-24-2012, 09:55 AM
Thanks so much for the help!
Hmm.. i tried to copy what you did but it looks like there's something wrong :S

11-24-2012, 10:03 AM
I didn't use weight map nor Show Output in these tests..

11-24-2012, 10:06 AM
See 4th and 5th screen-shots - if I would make weight map and plug to Max input in Occlusion node, I could control distance in which occlusion is gathering data. Weight map would be distance in meters. 1.0 = 1 meter. So 25mm would require using 0.025 in Set Map Value.

11-24-2012, 10:27 AM
I plugged weight map into Max.. but it's not doing a "gradient" effect.

11-24-2012, 10:31 AM
Your weight map - if you didn't edit old one - has red color inside of box - it's 1.0 value = 1 METER range used in occlusion node.

Using weight map was just idea to control occlusion. You don't have to use it.

11-24-2012, 10:43 AM
sorry for all the confusion :S
If I don't use the weightmap thougho I get this weird splotching effect.

11-24-2012, 12:15 PM
This is what I have now.. I ended up using the occlusion I node.. is there a way to blur / soften the shadows?

11-24-2012, 12:34 PM
I tried the fast blur but it crashes LW :S

11-24-2012, 12:44 PM
The splotching is down to having interpolation turned on in the occlusion... same deal as rad basically. For best results, kill interpolation, and hit it with unified sampling/AS/AA... http://www.youtube.com/watch?v=UgNB9tZWUmM&feature=g-upl Go for something akin to 4 base shading samples, and tweak, play up the max till u got what u need.

Though the reason u got all this is on account of you ambient... thats why there's light inside the box, even when closed... cos ambient casts no shadows. One option to go without the need for occlusion is to just kil the ambient, and add to/ramp up your lights to give the bright, full scene lighting Im assuming ur aiming for. Your other option, and much better imo... is to still drop the occlusion, set ambient to 0 go back to GI, and use backdrop only (so no lights/bounces taken)... interpolated, high rpe, and white as the BG colour, adjust GI% to taste. The same essential effect can be achieved by using no BG colour (so black), GI still on BGonly, but this time with ambient occlusion turned on (in GI opts I mean here), and then adjust the rad% and ambient light level/colour. Fast renders, great quality, no splotch/flicker, easy peasy.

11-24-2012, 01:00 PM
I tried that.. I get about 4-5 minutes per frame.. this way I get about 3 minutes per frame.. is that high for reflections / transparency? Seems alright doesn't it? I'm rendering at 1920x1080

- - - Updated - - -

and 8 min samples

11-24-2012, 02:30 PM
Very quick tweak of some parts only:


just imho ofcourse:
-listen to RH :)
-forget kray and fprime, native will do fine (hey I said imho)
-take down global light and shading sampling to 1 (no clue why they start at 8, change them up later to add weighting to either type)
-get rid of ambient
-100% GI resolution
-get rid of white planes to GI illuminate as it introduces splotches, use them as refl panels though
-use background color as more subtle illum.
-add diffuse light for some sort of shadowing
-use other surfaces, take off double sided or in other cases add it (labels)
-turn off radiosity influence on almost 100% transp. surfaces like the plastic encasings (it adds rendertime and helps nothing)
-turn off use transparency for GI here, it adds a lot of rendertime
-use the surface refl and refr blurring in the node, not the old surface panel, it doesn't work when using material node.
-do fading out of objects etc by splitting out scenes with and without and fading in post. Much better and faster.
-possibly up the rpe a bit more, to 500/250.. but doesn't feel too necessary. Should be able to do this without caching, it's minutes per frame anyway.


I get +- 1 to 2 min rendertime on a 2600k intel. Would seem a reasonable rendertime