PDA

View Full Version : license.lwk & lwsdk import error



Foraker
11-10-2012, 09:01 AM
Hello, I seem to be having two problems with a my new install of LW11. I'm not sure if they are related.

Issue 1: I just installed LW 11.0.3 on Windows 8 64-bit and launched it. It started in discovery mode and produced a popup saying no license key found. Note, this was not a 'splash screen', but a simple popup with an OK button. The Newtek instuctions say: Run Lightwave, A 'Splash Screen' will appear. So that didn't happen.

I dragged the license.lwk over to the main LW window and restarted. Okay, not in discovery mode anymore. However, when I go to help about splash screen it does not show me my license, just my dongle id. This is keeping me from registering LW11 on the NewTek site, well until I can figure out what text in the .lwk file I can use to register.

I've uninstalled (deleting my lw user info also) and reinstalled. It turned out exactly as above. No splash screen.


Issue 2: Every time I start modeler or layout I get the PCore Console popup listing 20 or 30 plugin .py scripts failing to import lwsdk, each having this error:

import error: no module named lwsdk

On my reinstall from above, I stayed in discovery mode for a couple of lunches trying to get a splash screen. I got this error popup there as well. Don't know the relavants of this, just throwing it in as extra detail.

My googles have not found much. I noticed a zipped up lwsdk11.0.zip file in my sdk folder, so I tried uncompressing that. but that didn't help.

Any help out there?

thanks