PDA

View Full Version : Compositing buffer export + selected objects = no antialiasing?



Tommy_TGCG
10-18-2012, 09:00 AM
Hello!

I'm trying to setup some extra buffers for specific objects in my scene.

I'm adding several "Compositing Buffer Exports" image filters, each with a different name and different object selections. Basically I'm trying to make masks for these objects.

I noticed that the "diffuse" buffer is creating a white, alpha-like image for the selected objects. Strange naming, but hey, that's what I need so OK, especially since there is no "alpha" buffer in the filter options.

Now for the problem:

The filters work... but the resulting images are antialiased only against the background!
If a separated object is overlapping another objects in the scene (which is not in the render pass, because of the selection) THE RESULT IS A JAGGED EDGE.
I'm not talking about buffers that are not supposed to be aliased by design like depth or normals... this is a buffer that is PARTLY ANTIALIASED ;). Now this must be useful for something... (any ideas?) but not what I need.

Please tell me if this is the expected behavior? and if so, what other buffer/ method can I use to produce simple masks? Without plugins or nodes - yes I know about Janus and Dpont etc. but my bosses insist on using native LW only - for the sake of simplicity.
Regards,
Thomas

dwburman
10-20-2012, 09:51 AM
I'll sometimes use the matte settings for objects if I need to separate them. I'm not sure that's what you're asking about, though. Hmmm, I wonder if you'll still get the jaggies if you set the hidden objects alpha to 'constant black' in the scene editor.