PDA

View Full Version : VPR/F9 render discrepency in shadows



SkiddlyMcZ
09-23-2012, 07:13 AM
This is odd... see attached image.

I'm demo-ing the trial version of LW 11.03 and using this test scene. I've barely begun working on it, so ignore its primitive nature. ;)

But anyway, as you can see the light in my lamp is behaving normally in the VPR render, but not at all in the F9 render.
I've looked all over the place to make sure I don't have anything excluded from shadows or light, and everything is pretty much at default, except I have an inverse square falloff on the lamp point light and final gather enabled.

Any ideas why the F9 render isn't working right? Something I've overlooked?

Thanks. :)

jasonwestmas
09-23-2012, 09:31 AM
yeah I have noticed this but not lately in LW11.03. I tend to just create new light types. Takes a little more time but it tends to work better.


Did you report this bug in fogbugz?

SkiddlyMcZ
09-23-2012, 10:00 AM
yeah I have noticed this but not lately in LW11.03. I tend to just create new light types. Takes a little more time but it tends to work better.


Did you report this bug in fogbugz?

Well, I'm using the latest trial version, says 11.03 and it's definitely happening as I wrote in the other thread - make new light, change light type, light breaks in render but not in VPR.

No I haven't reported it as a bug, I figured I'd wait to see if it is in fact a bug or if there's just something funky about my scene, and right now I'm trying to evaluate it, not debug it. ;)

jasonwestmas
09-23-2012, 10:56 AM
oh you know what. . . I remember now, duh. . .there has been problems with certain light types and inverse square. It looks like NT have not fixed that yet. So yeah this is a known problem between VPR and F9. So it's not that F9 isn't showing the light in the render but that VPR shows inverse square 100-200% brighter or with a smaller falloff which makes the light appear brighter, most likely.

I believe I reported the problem. I'll try again.

SkiddlyMcZ
09-23-2012, 11:11 AM
oh you know what. . . I remember now, duh. . .there has been problems with certain light types and inverse square. It looks like NT have not fixed that yet. So yeah this is a known problem between VPR and F9. So it's not that F9 isn't showing the light in the render but that VPR shows inverse square 100-200% brighter or with a smaller falloff which makes the light appear brighter, most likely.

I believe I reported the problem. I'll try again.

I had thought about that but even disabling falloff left the light broken.

But I'm still not convinced there isn't something wrong with my test scene - the lampshade in particular. I'm still testing it, but adjusting a combination of translucency and transparency seems to break something too. Unless there's just something wrong with my geometry.

At any rate I found the bug fog link, but it wasn't loading, so I guess I'll have to try later.

dwburman
10-02-2012, 08:17 PM
VPR is in draft mode by default. Draft mode turns off some things like multiple bounces in GI.

The VPR settings are on the upper right of the viewport. Look for the stack of 3 lines.