PDA

View Full Version : Shadows Not Working



VictoryX
09-20-2012, 09:06 AM
Working on a scene in Lightwave and I'm trying to get the shadow Alphas. So i set my surface properties to Shadow Density so that only shadows will appear in the Alpha. For some reason though, only parts of the shadow are showing up.

In this first image you can see the ground & boxes catching the shadow from the ship just fine.
107946

In this second image of the alpha, you can see that the ground shadow alpha is fine and the tops of the boxes shadow alpha is fine but the side shadow alphas are not showing up.
107947


Any insight on why this may be happening? Need more information let me know. I can zip the scene if needed.

Areyos Alektor
09-20-2012, 05:41 PM
If you can zip the scene will actually be easier to answer you :)

- - - Updated - - -

If you can zip the scene will actually be easier to answer you :)

Ryan Roye
09-20-2012, 08:40 PM
Hmm... Does your scene contain lights that are excluding objects? Or objects that are set to ignore any lights? IE: If you have a light affect only a character model but not the environment, the character will not project a shadow even if you have shadows enabled because the environment isn't included.

VictoryX
09-20-2012, 09:28 PM
Here is a zipped folder containing the files for the scene I'm working on. Hopefully they are all there.

107981

Ryan Roye
09-20-2012, 10:59 PM
Tricky indeed... I don't think shadow maps are going to cut it even though I can't think of why this isn't working. I toyed with it a while and I'm stumped for a simple solution. I can think of a way to do it by using a UV map and an overlay image of the ship's shadow (painted white), but that'd be a last resort option. There has to be an easier way to do it...

VictoryX
09-20-2012, 11:25 PM
It just seems so queer to me that the shadow would should up on one side of the surfaced cube but not the other, when they have the exact surface properties.

Slartibartfast
09-23-2012, 09:35 AM
Hi VictoryX,

It's because the sides of the cubes aren't shadowed. They're dark only due to shading - nothing is casting a shadow on the dark sides of the cubes.
(I didn't actually look at your scene, but I made a test render with a light and two spheres, lined up from left to right. Only the shadow from the left ball showed white in alpha image, whilst the dark side (facing right) was black in alpha.)

This is my first post here, so don't be to mad at me if I misunderstood anything, or put the reply in the wrong place :-)