PDA

View Full Version : OGL Texture motion



Chrusion
09-17-2012, 12:37 PM
In LW 11 is there a setting I'm not seeing that enables you to see texture motions (enveloped position Z of planar mapped image) in Texture Shaded viewports when you scrub the timeline?

The only way I've been able to check visual speed of textures and adjust is to make a Preview using viewport set to VPR with no raytracing or GI for the fastest possible rendering.

monovich
09-17-2012, 04:41 PM
It is possible. Switch between GLSL and Multitexture OGL. Also try parenting the texture to a null and animating the null. I've done a bunch with animated planar textures in the past, and it can definitely work in plain old OpenGL preview mode.

Chrusion
09-17-2012, 08:50 PM
Just switched from Multitexture Shaders to GLSL Shaders... no change. Isn't this the way OGL used to work for many versions when first introduced? I don't remember having to "convert" to a Ref Null to see an image map move in OGL. The use of Ref Nulls instead of keyframed channels is many times more desirable, so dropping support for something so basic can't be acceptable.

prometheus
09-18-2012, 02:57 AM
Just switched from Multitexture Shaders to GLSL Shaders... no change. Isn't this the way OGL used to work for many versions when first introduced? I don't remember having to "convert" to a Ref Null to see an image map move in OGL. The use of Ref Nulls instead of keyframed channels is many times more desirable, so dropping support for something so basic can't be acceptable.

Youré using some procedural textures right? a lof of the procedurals can´t be seen even with GLSL shaders and multitextures, newtek should have fixed and worked on that a little more, I think they dropped working on that due to VPR or something, or maybe the textures themself were to hard to fix?

Chrusion
09-18-2012, 10:23 AM
LOL... how the heck did you miss "planar mapped image?" I'm a bit worried about you now. Com'on, don't fail me now! :-P

prometheus
09-18-2012, 10:54 AM
LOL... how the heck did you miss "planar mapped image?" I'm a bit worried about you now. Com'on, don't fail me now! :-P

Lol... Im quite worried too, I noticed it just after my post, but I just didn´t bother posting another useless post..haha:)

4 hours of sleep, and I have also been having a cold...a little explanation perhaps.

monovich
09-18-2012, 11:38 AM
switch your geometry acceleration to streaming instead of buffered. that triggers it and forces it to evaluate the texture every frame.

Chrusion
09-18-2012, 11:46 AM
BAH-JING!! That's the one! Thanks monovich! That particular option sounded 'scary' to me, so I didn't bother investigating. Somethings in LW need to be less computer programesee. Plain english works for me. That or a short parenthetical description or tool tip like: (enable OGL animated textures).

So, what else does streaming do?

monovich
09-18-2012, 11:59 AM
I think the texture thing is just a side effect. I thought it had more to do with speeding up the openGL preview by not recalculating object shapes/deformations every frame unless perhaps the object shape/displacement as animated.

But really I don't know. :)