PDA

View Full Version : Mac Keyboard



Stephen0523
08-28-2012, 01:24 PM
Hi all. I used to be able to use my Function key to do things like "Rest on Ground" F3 etc. For some reason it has stopped working.
Any ideas?

Cheers
Stephen

BeeVee
08-28-2012, 02:03 PM
Did you upgrade OSX? It's probably because your Function Keys now do the shortcuts on the keys and if you actually want to use them as Function Keys you need to hold down Command or something. I don't have my Mac in front of me to check, or to see if there's a way to stop that being default behaviour.

B

Stephen0523
08-28-2012, 04:06 PM
Hi. I tried the Control, Option and the Command keys with no luck.

UnCommonGrafx
08-28-2012, 04:13 PM
It's that blasted FN key to the right of Enter.

ctrl-f8 does't work as well as a few of the other shortcuts that use the function keys. Truth be told, a 'normal' keyboard is better if you are willing to part with the shortcuts offered.

Hoping someone has better info.

p.s., already changed it so that the keyboard is supposed to be 'normal', however, it's not and some shortcuts seem to be hardwired.

corsa
08-28-2012, 04:31 PM
In addition to going to "System Prefs -> Keyboard" and selecting "Use all F1, F2, etc. keys as standard function keys" you should also go to "System Prefs -> Mission Control" (or "Expose", depending on your version of OS X) and change/clear out any Expose keyboard shortcuts that use function keys.

(For example, by default on my Mac, I see "Show Dashboard" is mapped to F12. So even if you have your function keys set as "standard", pressing F12 would not function as you would like it to in LW.)

You can also check "System Prefs -> Keyboard" and then the "Keyboard Shortcuts" tab to see if any other function keys are mapped to things that would interfere.

EDIT: I just checked under the Keyboard Shortcuts tab and through some of the various sections there, and I see a lot of control-function key combos mapped to things. Go in and deactivate all those too.

raw-m
08-28-2012, 11:29 PM
...and Show Keyboard & Character Viewers.... check the keys are working!

meshpig
08-29-2012, 12:05 AM
... if none of the above works try "SystemPrefs../Accessibility/Mouse and Trackpad and uncheck "Enable Mouse Keys". If on it hijacks half ya keyboard.