PDA

View Full Version : What version should not open 11.0.3 scenes?



Philbert
08-28-2012, 07:34 AM
I'm writing a tutorial and including an 11.0.3 scene file. I assume I should post a warning to readers to not open it with certain versions of LightWave. Is that versions 9.6 and below? I just want to have it straight before publishing.

Danner
08-28-2012, 08:08 AM
Actually you could get in trouble opening it in 10 (color space config issue screws up your whole interface!)

Philbert
08-28-2012, 08:10 AM
Yeah that's the problem I was thinking of, I just couldn't remember when that was implemented.

Danner
08-28-2012, 08:24 AM
Found the info. a Quote from Chuck Baker


Important! Compatibility Notes on LightWave 10.1 Scene and Config Files:


Do not use 10.0 or earlier config files with 10.1, or vice versa.

The best way to insure this is to allow 10.1 to use the default location that it will create for its own config files.

If you are redirecting your config files instead of using the default locations, then you must make sure you are not redirecting to the same location and thus sharing the same config files between 10.0 and 10.1.


Do not run 10.0 or earlier versions and 10.1 at the same time.

If more than one version of a LightWave application is run, they will all use the same Hub. When you are running one version of LightWave and decide you wish to run any other version, you must shut down the applications and manually close the Hub before launching the next version.


Do not attempt to use LightWave 10.1 scene files using color space profiles in v10.0 or earlier versions.

There is a critical difference in that quotation marks are in use around the path and file name information for many of the scene file and config file color space parameters. This was instituted because many users are using colorspace profiles with spaces in the path or the name. Adding the quotes is the only reasonable option to address this.

This does mean that unless hand-edited to remove the quotation marks, 10.1 Scene files and config files are going to confuse earlier versions. Please understand, we will not be able to patch earlier versions to retrofit them for 10.1 content. Users will need to observe the precautions noted above for operating 10.1 and earlier editions on the same system.

What happens and what to do:

If you try to load 10.0 after running 10.1 or having used a 10.1 scene in 10.0, and the UI is showing strange colors and missing all text, then you need close out the app, clear the config files for 10.0 and restart.

dwburman
08-28-2012, 10:25 AM
I think it's just 10.0 that is the problem.

BeeVee
08-28-2012, 02:43 PM
10.0 and possibly before...

B

Philbert
08-28-2012, 06:01 PM
OK thanks, to be safe I'll just say 10.0 or earlier. It's a shame there isn't something they can do as a warning like a pop up when you try to load it. Suppose I'm using an older version for some reason and I download a scene from a website. That Site may not specify what version it was saved with.

Silkrooster
08-31-2012, 12:22 AM
What about saving your scene as an earlier version. I believe there is a version drop down box in the save as dialog box.

Philbert
08-31-2012, 12:28 AM
There is, but my scene uses linear color settings.