View Full Version : LWM Crash, now LW/LWM will not launch

08-18-2012, 05:36 PM
I was playing around with an lscript, and while doing so my LWM crashed.

Attempting to relaunch just got a Critical Error warning. Same with Layout.

Deleted the configs, but that doesn't seem to have made any difference.

Likely suspects? THANKS! :confused::confused::confused:

08-18-2012, 07:41 PM
Have you tried restarting? Sometimes I get display driver crashes when using lots of opengl apps and restarting typically fixes it.

08-18-2012, 07:51 PM
Have you tried restarting?
Yup: twice!

I figured this might be The Universe's way of saying "Install 11.0.3".

Still, it would be nice to know if:

the lscript had anything to do with it;
if the cfgs stored the 'poison' somewhere, and if so;
why deleting the cfgs didn't cure it (but they're rather scattered now, I might not have got them all);
which particular cfg is responsible, if any;
why a cfg even has the power to crash the app.

So, a whole CSI season of questions. Or at least a 3 show arc. :grumpy: :)

08-18-2012, 07:55 PM
do you mean re-start or re-boot?
I would suggest re-boot. Not soft boot either.

08-18-2012, 08:08 PM
Did and done. No help.

Installed 11.0.3. We'll see. 1907PDT.

08-18-2012, 10:51 PM
OK, installed 11.0.3. Modeler launched fine. Copied over the 3rd party plugins file, used SCAN DIRECTORY to add plugins, Modeler crashes,


Killed suspect directories, added plugins to Layout. Layout does not spontaneously crash, but once closed will not launch again.

In the C://Users/Jeric/AppData/Local/Temp directory, I see a suspicious number of files beginning with "lscript.nnnn", with n=numeric, that correspond to the times I've attempted to launch LW or LWM.... and yes, in fact everytime I try another is added.

Does LW and LWM attempt to run or open every lscript in the cfg file? These dumps are obviously related to the most recent lscript I installed, but I'm surprised that simply being in the folder forces LW/LWM to interact w/the script.

I'm also not sure which CFG file is causing the app to even find the poison scripts, since I believed I had managed to clear them all. One more try.... :cursin:

EDIT: sadly, a cool plugin crafted by iain_r is capable of generating poison ls files which can prevent lwm from launching. This may rely on Autoscan being turned on. Anyway, now I know the issue.

08-18-2012, 11:22 PM
Rename the Lscript folder and create a new empty one? Then try to relaunch?

08-18-2012, 11:59 PM
Just killing the suspect file is enough. I'm surprised though: Autoscan must do more than just look at the filenames, it must actually process the file a bit, otherwise it wouldnt' crash, no?

And now I gotz 11.0.3. >:^\

08-19-2012, 12:24 AM
Well, eliminating all Lscripts tells you if there is a problem in the folder or not.
If so, sort all contents by date. Delete everything from today(yesterday).
Then try to boot again.

08-19-2012, 12:55 AM
No, I already figured it out: it's ONE specific script that was generated by another script.

see here: http://forums.newtek.com/showthread.php?t=129816&highlight=instant+teapot