PDA

View Full Version : Ethernet Network issue with 10.2.8 update



Zarathustra
10-27-2003, 08:47 PM
This past weekend I went ahead and upgraded to 10.2.8. Everything sure seemed fine until I wanted to do a network render - ERROR! I couldn't connect my Macs.

Through many online searches (sorry, never saved the links) I found that this little bugger:

AppleGMACEthernet.kext

was updated to 1.3 and it's a disaster!

Luckily my suspicious nature prompted me to backup my 10.2.6, so I replaced the new version with the old 1.2.4 version and now everything is back to normal.

If any of you need this file, let me know.

Zarathustra
10-28-2003, 07:00 AM
I also just learned the hard way that upgrading to 10.2.8 also means I have to re-install the ATI Radeon hotfix, because there's apparently a different patch for 10.2.8.

policarpo
10-28-2003, 08:19 AM
yep yep.

10.2.8 seems to be running fine over here, but I don't do network rendering at the moment.

For what it is worth...don't upgrade to Panther either since the Graph Editor forces Layout to quit if so much as touch it. :)

Hopefully all of this will be resolved in the coming weeks.

Silly Apple making us struggle through their growing pains. :P

Zarathustra
10-28-2003, 08:33 AM
Well, I hope that [8] was made with Panther in mind. I'm awaiting my [8] but I feel bad for anyone who upped to Panther and doesn't plan on upping to [8] anytime soon.

I would doubt if Apple or NT would release anything for 7.5's Panther problems when [8] is on it's way.

That ethernet thing though....geez. What the F-, Apple? Some people couldn't even get their internet access to work. What the hell do you do then? How would you get help? Thankfully, mine worked despite the new lil' bugger from Apple.

eblu
10-28-2003, 09:04 AM
zar,
you installing the old .8 update or is this a new issue?

Apple pulled 10.2.8 very quickly after they realized there was a problem with the ethernet, and then they quickly put out an Updated 10.2.8, with an ethernet that works.

the problem as cited only affects 10BaseT connections (according to Apple)

http://docs.info.apple.com/article.html?artnum=107669

I suspect the answer is that you had the wrong 10.2.8 update.

Zarathustra
10-28-2003, 10:34 AM
I suspect the answer is that you had the wrong 10.2.8 update.

Suspicion incorrect. I stated above "This past weekend I went ahead and upgraded to 10.2.8." I used Software Update, so I installed the correct version unless SU made a mistake, which it shouldn't since that's the whole point of using SU.

mlinde
10-28-2003, 10:52 AM
I'm checking this now with 10.2.8 (on my iBook) vs. 10.2.6 on my G4.
Using Airport as the network connection works fine both ways.
I have to track down an extra ethernet cable, so I won't get to that right away, but did you make sure your network settings are correct on all the machines? I've found my settings changed after updates sometimes, and I know I've had to reset stuff when zapping PRAM or resetting the nvram settings.

Zarathustra
10-28-2003, 11:27 AM
I did not make sure the settings were the same, but I spent an hour trying every possible setting before giving up and searching for an answer online.
After replacing the file, everything immediately was back to normal.

Let me clarify - I could access the internet via ethernet. I could not connect my 2 Macs.
One of them was a dual 500 but has a dual gig card now. I did notice in that link above that Apple singled out the dual 500 as having trouble.

mlinde
10-28-2003, 11:40 AM
I just finished the ethernet test on my two machines, listed above. I can connect the iBook (10.2.8) to the G4 (10.2.6) via ethernet.

In addition, the version of my AppleGMACEthernet.kext on the iBook is 1.3.0

Is it possible you have the wrong 10.2.8? The version on my iBook (using Apple System Profiler for the additional information) is 6R73. If your ASP shows a different version of 10.2.8, somehow you've got the old patch.

The odd thing is, if you can connect to the internet, the ethernet connection is working. If you can't connect to another Mac, there may be an issue with filesharing or AppleTalk.

I'm not saying you didn't try a bunch of things, I'm just looking at the problem and trying to make suggestions. Were both machines running 10.2.8 when you tried to connect? If you launch Apple's Network Utility and look at the info settings for en0, are there any odd errors?

Miles
10-28-2003, 11:54 AM
I'm sure you may have already thought of checking this, but under you File Sharing Prefs the FireWall settings may be causing the issue. I just made the jump from X.1.5-to-X.3 and hadn't realized Apple started incorporating their own FireWall into the OS. I'm guessing they did this sometime back in X.2.? Just a thought...

Zarathustra
10-28-2003, 12:30 PM
Well both machines had just been upped to 10.2.8 (6R73).
The main machine could connect to the secondary.
The main had internet access.
The secondary could not connect to the main.
I honestly can't remember if I tested the secondary's internet connection or not.

Puzzling situation. When I downgraded the file (simultaneously on both) to 1.2.4 then all connections were re-established.

Everything now works fine.

mlinde
10-28-2003, 01:47 PM
Hmm.
I'm assuming the secondary is the G4/500 you mentioned. FWIW, I haven't heard of anyone having problems with the downgrade you performed, so if it works for you, it works.

Did you find any advantages to 10.2.8 over an earlier release?

Zarathustra
10-28-2003, 02:54 PM
Main is the former dual 500. Secondary was a 400 that I upped to 1g.

Honestly, I haven't noticed any improvements. It was supposed to be a combined upgrade with improved java support for Safari which is total BS. I still have java problems with Safari.

I'm not bold enough to try the harddisk update. :(