PDA

View Full Version : Missing Plugins



kirkeric
07-14-2012, 12:10 PM
Hello,

I recently reinstalled LW 11 with the latest updated, actually installed it a couple times. Now, I am having problems with missing plugins. First it was missing Rounder, which I found in the plugins folder. Not sure why it didn't work but in this case, I moved it and simply placed it back in and now it works.

As I went forward, I began noticing other ones missing too, such as the spline and bezier draw ones. However, they are not in the folder to try the same approach.

Is there any way to get all the plugins back in order?

Thanks,
Eric

Matt
07-14-2012, 02:56 PM
Have you tried deleting your config files?

kirkeric
07-15-2012, 06:49 AM
no i haven't. Can you tell me how to go about doing that?

Just to add, I've done yet another clean install. Things seem to be running fine but I am baffled at where the spline draw and bezier draw functions have gone. I can't really tell what all might be missing as I happen to just be looking for those ones.

Thanks,
Eric



Have you tried deleting your config files?

BeeVee
07-16-2012, 02:23 AM
Just do a scan for plugins. Hit Alt-F11 and the Scan Directory button on the right of the window. You need to look for your LightWave\support\plugins folder and there'll be a pause and then LightWave will give you a message saying "xxx plugins found in yyy files".

B

jwiede
07-16-2012, 04:48 AM
Is there any word from the LW devs about finding the root cause of this sporadic loss of plugins? It happens just often enough to be annoying, and recovery is really time-consuming because of menu items being invalidated upon "re-cataloging" third-party plugins -- a new wrinkle that appeared in LW10, and made this bug significantly more annoying when it happens.

Finding reliable repros is difficult, understood, but some more proactive debugging than users can do (involving src changes) ought to be able to flag and catch when it happens (f.e. based on plugin list checksum changes), and from there track down cause.