PDA

View Full Version : Z depth in LW11 Help!



battery555
06-20-2012, 04:10 AM
I need to render Z depth in LW11 for AE depth of field. As LW11 no longer support render buffer export. I tried compositing buffer export instead. With the default setting (Normalize Depth to 8-bit checked the renders came out flat without any depth. I played around with the buffer depth by unchecking the "normalize option but without success. I couldn't get much depth out of it. Can someone shad some lights on this? Many thanks!

AbstractTech3D
06-20-2012, 04:19 AM
Have you entered appropriate values into the fields 'Z Buffer Minimum / Maximum' under Render Globals / Render?

You might also want to read this article, in reference to a 'Focus Pass':
http://lightwiki.net/wiki/Multipass_Rendering_with_Filter_Node_Editors#Focus _Pass
…as an alternative approach.

rcallicotte
06-20-2012, 08:03 AM
I was able to create a z-buffer pass using LW11. Should be some help around here somewhere...

evolross
06-20-2012, 11:34 AM
Here's a simple scene that uses Hypervoxels. I've added the Compositing Buffer Export and it's currently set to render to the RGB of the Image Viewer, so if you F9 you'll see the depth pass. I've also inverted it and normalized it to 8-bit.

In the Compositing Buffer Export you can set if you want the buffer to save out as a file, another layer in the Image Viewer, or to the main RGB render (as it's currently set).

battery555
06-20-2012, 07:37 PM
Thanks guys for the inputs!

AbstractTech3D,
Thanks for the link. Will check that out!

Evolross,
Thanks for the sample scene. I did exactly like what you did but still there isn't much depth from the renders :( The other point is why there's banding? I saw that in your sample scene as well.

battery555
06-21-2012, 12:06 AM
Have you entered appropriate values into the fields 'Z Buffer Minimum / Maximum' under Render Globals / Render?

You might also want to read this article, in reference to a 'Focus Pass':
http://lightwiki.net/wiki/Multipass_Rendering_with_Filter_Node_Editors#Focus _Pass
…as an alternative approach.

I'm not getting any decent result even with minim/maximum z buffer option. I decided to check on your given link. In fig.25 the sampled bat mobil focus depth is excellent. Below are some of my challenges to follow the "brief" instructions:
1) the node image is too small to see what node connect to which
2) Whats DP_NPF mentioned in the brief?
3) Whats Global 3D shading mode?

Anyone can chime in?

evolross
06-21-2012, 09:45 AM
I did exactly like what you did but still there isn't much depth from the renders :( The other point is why there's banding? I saw that in your sample scene as well.
It looks like you're getting a good depth in your render, you need to invert it though to make the background black and the foreground white.

The banding is likely from the "Normalize to 8-bit". If you uncheck this, you'll get a 32-bit depth render with no banding, but the depth won't look right unless you adjust/normalize it in post. Even if you don't tweak it in post, your DOF plugin should still work because the depth information is there, you may need to tweak the DOF plugin's values though to get the look you want.

You can set the buffer depth to "normalize" it yourself in the render. The buffer depth is like the "back wall" of the depth buffer, so in my scene I uploaded 8m looks pretty good.

AbstractTech3D
06-24-2012, 04:42 AM
I'm not getting any decent result even with minim/maximum z buffer option. I decided to check on your given link. In fig.25 the sampled bat mobil focus depth is excellent. Below are some of my challenges to follow the "brief" instructions:
1) the node image is too small to see what node connect to which
2) Whats DP_NPF mentioned in the brief?
3) Whats Global 3D shading mode?

Anyone can chime in?

So the maximum z buffer field probably needs to be reduced from 1000000 down to something like 10 - or whatever is appropriate for your scene.

1) I've replicated the setup in the attached image to this reply (if I'm not mistaken about it)
2)DP_NPF = Node Pixel Filter - added under 'Add Pixel Filter'
3) Global 3D shading mode found by double clicking pixel filter destination node in nodal context - again, see attached image.

battery555
06-24-2012, 11:55 PM
1) I've replicated the setup in the attached image to this reply (if I'm not mistaken about it)
2)DP_NPF = Node Pixel Filter - added under 'Add Pixel Filter'
3) Global 3D shading mode found by double clicking pixel filter destination node in nodal context - again, see attached image.
Thank you so much AbstractTech! You last post is extremely helpful. Finally I managed to get some good Z depth. Kudos! :beerchug: