PDA

View Full Version : Spherical Map For Reflection



HolyMonkey-
06-07-2012, 03:18 AM
How do you go about setting up a sphere with a texture around the object in order to get reflection on say, water.



I created water

Created a big sphere.

0 Diff

100 Lumnosity (Added cloud texture here)

Render

- Render only shows gray color of lumi and no reflections.

Ignore that it says 0 lumi on the picture, just a quick test..

http://forums.newtek.com/attachment.php?attachmentid=104892&stc=1&d=1339060676

Danner
06-07-2012, 07:11 AM
Not sure what you are missing, maybe the sphere has the normals facing outward instead of inward? Is the sphere object marked as "seen by rays"? You could alternatively apply the reflection map to the water in the surface edtor in the Environment tab, reflection options-spherical map. Or map the image to the backdrop of the scene using textured environment.

SteveH
06-07-2012, 07:33 AM
Perhaps your sphere is so large compared to your view from the camera that you are only seeing a tiny section of your cloudy sky image. Just for grins and giggles reduce the size of the dome by 50% and render another test to see if that makes any difference. I agree with Danner though - most likely your have the polys pointing the wrong way. That's an easy thing to forget to do.

HolyMonkey-
06-07-2012, 01:36 PM
I cant test it right now, but Ill post the scene tomorow.

Using Double sided surface, and normals are facing correctly ;)

Ive had this problem for quite some time so there must be some thing im missing, but Ill let you guys dig it out tomorow if you can be bothered.... heh.. thanks!

HolyMonkey-
06-08-2012, 12:26 AM
Badum Ts!

forums.newtek.com/attachment.php?attachmentid=104922&stc=1&d=1339136668

gerry_g
06-08-2012, 03:05 PM
http://dl.dropbox.com/u/30264782/Screen%20shot%202012-06-08%20at%2021.56.17.png

Background options texture environment cylindrical mode, not load background image which is only seen in viewport not by the scene.

Quick revision is here
http://dl.dropbox.com/u/30264782/Temp_REVISED.zip

HolyMonkey-
06-09-2012, 09:08 AM
http://dl.dropbox.com/u/30264782/Screen%20shot%202012-06-08%20at%2021.56.17.png

Background options texture environment cylindrical mode, not load background image which is only seen in viewport not by the scene.

Quick revision is here
http://dl.dropbox.com/u/30264782/Temp_REVISED.zip

Cheers!

Although, This still leaves my initial question unanswered, in some scenes you want to load your image onto a sphere instead of a textured environment, any idea why my sphere didn't throw of any reflection?

dwburman
06-09-2012, 09:16 AM
If you want to see the color of the image, you need to put the image in the color channel, not the luma channel. The ocean is reflecting gray because your sphere's surface color is gray.

[edit] That might not be the only issue. I'm still looking at the scene.
It is strange... I added a ball to the scene. If I copy the surface from the sky to the ball, the ocean reflects the ball. If I copy the ocean surface to the ball it does not reflect the sky. I see nothing on the sky object to prevent it from being reflected.

I made clone of the ball I added, enlarged it so that it's even bigger than the sky sphere you added, and the ocean is reflecting the ball I added and not the one you added.

Okay, I got it.

In the scene editor, you have have the Sky object turned off. You need to have the A column checked for the sky object (Layer 2) and make sure you copy the picture from the Luminance channel to the Color channel. You can leave it in the luma channel and change it's blend mode to Additive and use that in conjunction with the normal luma setting to overdrive the image into HDR land.

JoePoe
06-09-2012, 11:22 AM
also, along with the above (:agree:) if you want to go solely with the image on the sphere don't forget to uncheck "unseen by camera" in object properties for the sky object.

HolyMonkey-
06-10-2012, 12:40 PM
If you want to see the color of the image, you need to put the image in the color channel, not the luma channel. The ocean is reflecting gray because your sphere's surface color is gray.

[edit] That might not be the only issue. I'm still looking at the scene.
It is strange... I added a ball to the scene. If I copy the surface from the sky to the ball, the ocean reflects the ball. If I copy the ocean surface to the ball it does not reflect the sky. I see nothing on the sky object to prevent it from being reflected.

I made clone of the ball I added, enlarged it so that it's even bigger than the sky sphere you added, and the ocean is reflecting the ball I added and not the one you added.

Okay, I got it.

In the scene editor, you have have the Sky object turned off. You need to have the A column checked for the sky object (Layer 2) and make sure you copy the picture from the Luminance channel to the Color channel. You can leave it in the luma channel and change it's blend mode to Additive and use that in conjunction with the normal luma setting to overdrive the image into HDR land.

Seriously? I had it unchecked? I will look at the scene tomorow, however this strikes me quite oddly. I thought if you add an object through lumi channel it ought to reflect the colors of the image through the lumi channel?

This techneque is often used in software, such as Maya,3dsmax and Cinema4D where you turn off EVERYTHING, and just add a texture to lumi channel in order to get lighting from the image with the color of the image and not the initial "gray" color from the color channel.

Thank you for your help though! =)