PDA

View Full Version : HID device manager not working



Photogram
05-27-2012, 02:35 PM
Please help me,

My virtual studio device manager doesn't recognize any devices...

I wish to record with the space navigator.
The 3d mouse is working in Modeler and Layout but not in virtual Studio...

I've reinstalled the driver check the configs and restart the system and no changes :(

Photogram
05-27-2012, 02:42 PM
Lightwave 11 x64 build 2253
Vista 64

Was working in previous builds...

Photogram
05-27-2012, 02:50 PM
Everything is working in Lightwave 10.1 build 2161
And it is easyier to setup but my scene is build in LW11 with instances

djlithium
05-27-2012, 03:39 PM
Hi there.
I have the 3Dconnexion puck mouse and while I haven't tried to record in Virtual Studio tools (I'm a big fan of VST!) I will do a check and see if its possible. It may be that since the device is already in "LightWave" its not supported for VST directly but the puck mice nodes are there so there has to be a way.
You may need to set up a trait on scene item first and then use nodal to get the device stream.
Let me poke around and see. :)

Photogram
05-27-2012, 03:56 PM
My scene is all set.

I used the scene CameraSetup_Space_Navigator.lws from the Newtek NewContent in Virtual Studio Tools/DaveV/Scenes folder

All the nodes are there this is not working because HID manager is not detecting any devices.. so i cannot enable the space navigator and go to settings to configure etc...

The device manager window is empty...

I think my problem is related to my configuration in HumanInterface.cfg

also the file Manager_HID.cfg is empty

Maybe because my config folder is not at the usual c:/Users/name/.newtek ...

I tested delete the configs and no changes...

gclayton
05-27-2012, 09:10 PM
You have probably already checked this but...

Have you actually Enabled the HID manager in the Device manager window?

It is disabled by default.

I have the SpaceNavigator for NoteBooks connected on my Win. 7 x64 PC and after enabling the HID Manager and the SpaceNavigator I am getting input from the device.

In the Device Manager you need to check the Enable column for the HID Manager and the Device you wish to use.

Photogram
05-27-2012, 09:38 PM
Well

When i check in the device manager under Human Interface device there are about 25 HID settings and i cannot find the space navigator.

Everythings are enable even my wacom tablet that is supposed to appear in the Lightwave HID manager