View Full Version : lightwave uv maps to blender

05-26-2012, 01:57 PM
Im trying to export a furniture set from lightwave to blender using a obj format. When its in blender the uv's are totally ruined. The UV polygons seem to go toward a single point in the UV view. I've tried all the other export formats but they either dont work or dont export with uv's or textures.

Help is appreciated.

05-26-2012, 02:29 PM
Try unwelding points prior exporting to OBJ..

05-26-2012, 03:56 PM
have you tried different importing options ? vertex order maybe ..

05-26-2012, 04:46 PM
ive tried unwelding everything but that doesnt seem to do it. switching to vertex order in the import settings doesnt work either.

05-26-2012, 05:45 PM
did you tried lwo format ?

05-26-2012, 06:37 PM
lwo format imports the UV's fine but no textures.

05-26-2012, 06:45 PM
Can you share a portion of the object?

05-26-2012, 11:14 PM
here you go

05-27-2012, 02:50 AM
I don't know why you have that going on. Seems to be working fine here.

Attached the exported OBJ I used to import into Blender and the Blender scene. Anyway you still have to go through those reassigning texture shores.

Have you checked the UV of the used OBJ to see if it's ok?

If you allow my curiosity why would you render in Blender? Testing Cycles?

Good Luck

05-27-2012, 02:44 PM
Now when I try to import a lwo into blender it also has bad uv's.There was a time when I could just import obj files into blender and there wouldnt be any touble. What lightwave version are you using?

The reason im using blender is because im putting together a game level in it for unity. The furniture was from turbosquid and they were in 3d max format. They exported the best in lightwave so I decided to go from 3d max, to lightwave, to blender.

05-27-2012, 04:17 PM
What version of Blender are you using?

When I import the lwo you uploaded in Blender 2.62 the UVs look the same as in LightWave 11.

Some parts of the UV are way outside of the UV tile space.

No textures applied but I'm thinking to get things working you'll just have to redo them in Blender.