PDA

View Full Version : ZBrush Disp. tears mesh



PeteS
05-04-2012, 11:44 AM
Ok, so I worked on a mesh that was based off the "base rhino mesh" from ZB. This saves some time, but also guarantees a blessed clean model to start off from without any ZB quirkiness. So, I do my thing and it looks decent in ZB, then do the export by the numbers to LW.

I notice some areas are having tears when I add either the normal map, or the displacement map. Please see pic below. Look around the eyes and the ears..and maybe a bit by the nose. Everything else looks fine, and am pretty happy. But not sure about these tears. I did read that I should try exporting a mesh from ZB that is not the base mesh. Maybe 2 or 3. Any ideas?

http://www.platinumplatypus.com/filechute/rhino%20ripsmall.jpg

VonBon
05-05-2012, 06:40 PM
Maybe some of the points needed to be merged in that area.
May want to use a fixed merged number, I've been having issues with
the merge function. Might be best to get in there manually and merge
Those points to be sure.

silviotoledo
05-05-2012, 06:48 PM
you need to increase the sub-d amount in lightwave.

You can also use adaptative subdivision on that area.

You can also edit the model on lightwave and use SMOOTH.

gerry_g
05-06-2012, 06:12 AM
You can also use adaptive subdivision on that area.

but surely thats the old method pre LW 10/11, the nodal setup offers no such parameters, at least none that I can find that allow such control, you now only have per object per pixel or per polygon none of which seem to do a great deal for this sort of problem, I think the the errors have more to do with density of edge loops and the density of geometry that results from this. The problem is most noticeable around the eye area and the base of the horn where the loops are packed the tightest, ZBrush likes even uniform meshes to work with that will subdivide well which is at odds with the classic method of controlling sub-patch objects by the use of edge looping, I doubt the problem will go away until Newtek introduces micro poly displacement,

PeteS
05-06-2012, 09:33 AM
you need to increase the sub-d amount in lightwave.

You can also use adaptative subdivision on that area.

You can also edit the model on lightwave and use SMOOTH.

I think I cranked it up to 10 or 15, with no difference.

I think I'll have to do a separate render with no DISP and comp that in. Maybe pull a alpha from the black holes.

gerry: I think you're right.

Meh, it'll prob look fine that way, just more work. I'll crank up the sub D to 20 just to see if it does anything.

Thanks for the head s up guys.

m.d.
05-07-2012, 11:04 AM
is this a vpr render or f9....

vpr goes by display subpatch level setting not render setting....

any tearing of my zbrush models was always due to low subpatch

jasonwestmas
05-07-2012, 12:01 PM
Do a UV check. This is most likely a UV displacement generation issue. Can I see the UV map overlay with the displacement image? Or there are artifacts in your normal map which tend to create black spots.

PeteS
05-07-2012, 08:50 PM
Do a UV check. This is most likely a UV displacement generation issue. Can I see the UV map overlay with the displacement image? Or there are artifacts in your normal map which tend to create black spots.

I used ZB UV's so there is no overlap. Also the textures look fine. The issue happens when I add the disp.

Though if you like. I can still post UV tomorrow.

probiner
05-07-2012, 09:15 PM
Question. Are there seams on such region?

You could post only the affected area of both the model and texture.

Cheers

jasonwestmas
05-08-2012, 08:23 AM
Still looks like a seams issue to me. If this is a 32-bit displacement image you might not be able to see the artifacting.

jasonwestmas
05-08-2012, 08:38 AM
-)Also, it is possible that your padding setting in zbrush is too low for this displacement image size.

-)Just for kicks click on the Check UV button in Zbrush and see if there is any red.

-)A last resort is to revert your level 1 mesh back to your unsculpted low poly obj before generating your map. It is possible that you have overlapping polygons around that eye area on your highest sculpting levels or on your base sub-D level.

What I would do is to tripple check for errors in the map. Go into modeler and select the polys around the eye so you know where they are on the UV map, and then really look hard at your images with your UV map selected. Those black triangles would look really tiny on your map. But do this with a normal map and 16-bit or 8 bit tiff. . . not a 32 bit tiff.

PeteS
05-08-2012, 09:01 AM
-)Also, it is possible that your padding setting in zbrush is too low for this displacement image size.

-)Just for kicks click on the Check UV button in Zbrush and see if there is any red.

-)A last resort is to revert your level 1 mesh back to your unsculpted low poly obj before generating your map. It is possible that you have overlapping polygons around that eye area on your highest sculpting levels or on your base sub-D level.

What I would do is to tripple check for errors in the map. Go into modeler and select the polys around the eye so you know where they are on the UV map, and then really look hard at your images with your UV map selected. Those black triangles would look really tiny on your map. But do this with a normal map and 16-bit or 8 bit tiff. . . not a 32 bit tiff.

I will definitely give that a check today. Once I bag out some work crap. I hope it'll work, as this will be rendered soon! Otherwise I'll be doing some comping.

PeteS
05-08-2012, 09:10 AM
Well thanks Jason, you hit it on the nose. There were some funky things going on there. Looks fine now. Only other little issue is the groves on the nose. They seem very harsh and deep. I think this is just a LW preview vs. ZB thing. Which I can live with. I did use inflate around that area some, which seems to cause this. But overall, very happy. Thanks all for the input!

http://www.platinumplatypus.com/filechute/eyfix.jpg

adamgibson
05-11-2012, 11:54 AM
Good UVs(no overlapping UVs) and an Optimized Mesh go a long way. Image looks good Pete:)