PDA

View Full Version : Mesh deformation slow down



SaturnX
04-29-2012, 06:18 AM
I'm getting serious mesh deformation slow down in v11.0.1

After alittle trouble shooting, I think the culprit is fiberFX. When I have all my fiberFX layers turned off, the mesh deformation speeds up, back to normal.

It may have something to do with Lightwave thinking 'draw' hair mode is on when clearly, it is firmly off in the FiberFX UI.

Has anyone else had similar problems?

VermilionCat
04-30-2012, 01:42 AM
FFX has a severe problem in v11.0.1.
It's pretty slow unless you ticked off those layers. Just deactivate FFX in the filter doesn't help it. But you loose your layer settings by doing that. In my opinion you just better to stick with v11 for the moment.

Greenlaw
04-30-2012, 02:20 AM
That happened to me once last week. After restarting my computer the slow down went away though, so I'm not sure what was up. I'll probably be working with hair/fur tests a lot this week so I'll let you know if it happens again and if I notice any particular cause.

SaturnX
04-30-2012, 01:00 PM
FFX has a severe problem in v11.0.1.
It's pretty slow unless you ticked off those layers. Just deactivate FFX in the filter doesn't help it. But you loose your layer settings by doing that. In my opinion you just better to stick with v11 for the moment.

Too late, I'm already committed fully to v11.0.1 (I thought we'd have bug fixes, not more things broken.. )

I had severe crashes using FFX in v11.0, v11.0.1 seemed to fix alot of that. Quite a relief actually.
I have 1500 frames in one of the shots I'm working on, involving a slow motion moth. So you can imagine how painful this has been.
It would crash approx every 10-12 frames. So there was plenty of trouble shooting involved and the culprit was always FFX.
It was hard work. Sometimes a bad frame, wouldn't crash when you did an F9 on it. So it was kind of random crashing at times which didn't help.
I had to keep changing layer settings in FFX, depending on what weight map was setup on which piece of geometry etc.
What might work on one frame, wouldn't work on another, so Layout would crash. But like i said already, 11.0.1 seemed to fix those rendering issues.

LW11.0 32bit seemed more consistant in not crashing on bad frames, but it can't handle the HDR lighting I have for more than one frame.
(I use LW64 for most of my rendering these days)

FFX is very capable. Hopefully NewTek will keep the patches coming.

VermilionCat
04-30-2012, 02:01 PM
Really? Hmmm, then maybe you're right since I didn't dig into that much like you did and what you are doing is way ahead than mine. I'll try again when the patch is available.

I have a question btw. Hope you can help me.
When you edit your guides in Layout sometimes you lose your edited guides. I don't understand what causes this. Is there any specific rules regarding this?

SaturnX
05-01-2012, 02:34 PM
That happened to me once last week. After restarting my computer the slow down went away though, so I'm not sure what was up. I'll probably be working with hair/fur tests a lot this week so I'll let you know if it happens again and if I notice any particular cause.

I can't seem to shake the slow down issue. I've tried it on two computers. It's the same in both 32bit and 64bit...

I'm able to turn off the ffx layers until i do a render so it's not too bad for now.

Greenlaw
05-01-2012, 02:52 PM
I just ran into this on a small test scene this morning. The scene was running fine last Friday. I'll let you know if I can figure what's bogging the scene down.

Greenlaw
05-01-2012, 03:02 PM
Oh, now that's weird.

I just reopened the scene and noticed the slowdown, so I opened the FFX panel to see what was up. That's when I saw that an additional object had FFX enabled that shouldn't have had it. Maybe this was a mistake I made but that's not the weird part. When I disabled this object and left FFX enabled for the object that was supposed have FFX, the scene sped back up to realtime again.

FYI, the object that was supposed to have FFX applied were guide chains animated using ClothFX, and that works perfectly fine in the scene. The object that slows down Lightwave with FFX enabled has FFX applied to a surface, not guides.

I'm guessing the slowdown has something to do with the FFX settings for that object because I haven't previously run into this slowdown with other objects where I've used surface based fibers.

Sorry, I don't have time right now to look at the settings (assuming that's where the problem is,) but I'll let you know what I learn when I able to revisit this scene and examine it more closely.

G.

Greenlaw
05-01-2012, 05:19 PM
I know this doesn't help you but I did figure out why that additional item was active in my scene file: when I disabled FFX for that item last Friday, I must have simply unchecked the On box, but of course you need to explicitly click the Deactivate button to permanently switch FFX off for a selected object. I already knew that but...d'oh! :)

I'll try to get back to learning what's causing my slowdown when that item is active later this evening.

Greenlaw
05-01-2012, 06:13 PM
Hmm. I'm seeing the FFX slowdown in another scene I'm working on in 11.0.1. I tried opening the file 11.0 but it crashes there. Reopens fine in 11.0.1 though. Not sure what's up yet.

Greenlaw
05-01-2012, 06:18 PM
At first I suspected the use of texture maps for Density and Scale, but that doesn't seem to be it. When I remove these, Layout's response is still slow until I deactivate FiberFX.

Weird. I don't think it was doing this before. Maybe it's a 11.0.1 bug?

Greenlaw
05-01-2012, 06:24 PM
I think it has to do with Fiber Density--set to zero, the scene speeds up again. Makes sense I guess but I don't understand why interactivity is affected when the Draw option is disabled. I would think Lightwave shouldn't be calculating this stuff unless Draw is enabled or until it's rendering.

Anyway, that's what I've got for now. Let me know if you find anything.

Greenlaw
05-01-2012, 07:02 PM
Okay, here's another bit of weirdness: remember the scene that was really slow earlier, where I disabled FiberFX from that one object that wasn't supposed to have FFX applied? I just reactivated and applied surface based FFX to it, and Layout's interactivity is just fine.

Next time this happens, I'm going to save the FFX settings to see if the slowdown can be reproduced with the settings in another scene.

Anyway, since you still have your 'slow scene' try this: save your FFX settings, fully deactivate FFX by removing the plug-in from Pixel Filter, and then save a copy of your scene and quite Lightwave. Now, launch Lightwave and reopen the file. Activate FFX and load the settings. Is it still slow?

Just curious.

G.

Markitect
05-02-2012, 06:57 AM
Okay, here's another bit of weirdness: remember the scene that was really slow earlier, where I disabled FiberFX from that one object that wasn't supposed to have FFX applied? I just reactivated and applied surface based FFX to it, and Layout's interactivity is just fine.

Next time this happens, I'm going to save the FFX settings to see if the slowdown can be reproduced with the settings in another scene.

Anyway, since you still have your 'slow scene' try this: save your FFX settings, fully deactivate FFX by removing the plug-in from Pixel Filter, and then save a copy of your scene and quite Lightwave. Now, launch Lightwave and reopen the file. Activate FFX and load the settings. Is it still slow?

Just curious.

G.


Hey G..

Thanks for that. Lots of interesting information there!
In the process of trying your suggestion I noticed something strange right away...

First I need to explain quickly the setup of the moth's body in my scene.
The moth is three different object layers. Body, Legs and wings.
For the body section for example, I applied hair to the body section via weightmaps. There is a weightmap for the head, Mid body and tail. All the hair is applied within layout only, so there's no hair guides from modeler etc. In order for each weightmap area to get different fiber settings, I had to 'clone' within ffx, the object layer for the body. So two clones of the body layer. (When i first started this scene initially in v11.0, FFX wouldn't let me apply hair via multiple weightmaps on the one object layer, that's the main reason for cloning the layer)

Now, this is the problem i noticed in trying your idea, the cloned items I have on the body via FFX for example now have options missing, in this case their texture option for Max Fiber Density. Infact, that option is now called Fiber Quantity in the cloned layer.

I'm going to have to investigate this further, I've a feeling re-installing v11.0 is on the cards...

SaturnX
05-02-2012, 06:58 AM
That last post was from me by the way... incase you're wondering! :)

SaturnX
05-02-2012, 07:10 AM
The surface options (bottom right of FFX) are grayed out also for cloned layers. damn.

SaturnX
05-02-2012, 07:28 AM
Cloned layers are messed up, they seem broken.
Editing the guides on cloned layers won't work either.

SaturnX
05-02-2012, 08:10 AM
I have 6 layers in all in FFX that I'm working with.
When I select one of these layers in particular and I then select one of the cloned layers, the proper Fiber Density texture options re-appear and the surface settings and Bias Vmap are unghosted.

... This seems to be happening randomly I might add.

Greenlaw
05-02-2012, 11:29 AM
I found that one of my R&D scenes with a character has the 'slowdown' issue, and like the other scene the slowdown only occurs when surface-based FiberFX is active. I tried the steps I described above and but I'm still seeing the slowdown in this scene. I'm quite certain it didn't have this slowdown earlier in the day yesterday so I'm not sure what's up. Unfortunately I can't submit this scene as fogbugz content, so I'll have somehow reproduce the problem in a generic scene.

I did attempt a workaround idea--so far the slowdown seems specific to surface based fibers, so I tried using Polygonize to make guide chains which I intended to use for guide chains based fibers. However, the 2-point polygon result of Polygonize was pretty messy--I got the guides chains but also a lot of extra 'crazy' fiber guides that shouldn't be there. And then when that loaded that into Modeler, I only got points, not 2-point polygons. Weird.

I'll try reconstructing a 'clean' version of the above scene and save settings from that, and then apply those settings to the known 'slow' scene. If this works it may serve as a workaround 'fix it' switch. Let you know how it goes.

G.

Greenlaw
05-02-2012, 11:31 AM
BTW, I'm using 11.0.1. I'm going to create an 11.0 version and see if that's any more stable. (For some reason the 11.0.1 scene crashes 11.0 when I try to open it there.)

Greenlaw
05-02-2012, 12:09 PM
Okay, a little more info:

When I recreate the scene in 11.0.1, the slowdown occurs because of high fiber density. I guess this is normal, but it's weird that it happens even when the OpenGL preview is off.

I tried recreating the scene in 11.0 but 11.0 apparently doesn't like the character model and crashes. Not sure what the issue is here yet.

Next I tried recreating the scene in 10.1, which accepts the model just fine. First I tried loading saved FFX settings from 11.0.1 but got a crash. Not too surprised about this since FFX apparently had a lot of updating since 10.1. On my second try, I recreated from scratch and manually entered the same settings. This worked but I'm seeing the same slow down in 10.1.

However, if I disable the OpenGL preview for FiberFX, the scene speeds up again. This leads me to believe that the OpenGL switch for FiberFX in 11.0.1 is partially broken--the fibers disappear when it's disabled but Lightwave is still calculating the data, which is didn't do in 10.1. When disabling FFX preview in 10.1, the interactivity is just fine.

I can't confirm this for 11.0 yet but I think I can recreate this situation in 11.0.

I hope another service pack will be coming soon. This and a couple of other issues I've run into would be considered show stoppers at my workplace. Well, I guess you could just disable FFX as soon as the scene opens and then enable again before rendering, but the list of workarounds I'm employing is getting a bit long now.

If I can reproduce this situation using a simple object I'll fogbugz it today.

G.

Greenlaw
05-02-2012, 02:41 PM
Just to be clear, to get 'normal' speed back in Layout when using FFX in 11.0.1, you must uncheck the On box for the item that's bogging down Layout, not just the Draw box. In Lightwave 10.1, unchecking only the Draw box will work as expected--speed should be 'normal' again.

To get the speed up, you must do this in the FiberFX panel. Disabling the FiberFX pixel filter from the Processing tab has no affect on this slowdown issue. (Well, unless you completely remove it of course, but we don't really want to do that do we? :)

This is workable I guess but it's a lot of 'gotchas' you have to keep track of.

G.

Greenlaw
05-02-2012, 02:43 PM
Alternatively, you can work exclusively with guide chains instead, which don't seem to cause the slowdown, or at least not nearly as much.

SaturnX
05-03-2012, 10:57 AM
Alternatively, you can work exclusively with guide chains instead, which don't seem to cause the slowdown, or at least not nearly as much.

Yeah, I was thinking that myself. I might give guide chains ago.
I had the moth setup for my needs through layout nicely, and the results were good. I might try to work back into this via v11.0 and try to work around the crashing. It's the fact that I'm working with slow motion footage, that's making it all the more painful! A 100 frame shot would be a breeze! lol

The absense of options that I was using in cloned layers has not been helpful either.

Greenlaw
05-03-2012, 12:04 PM
FYI, there's something you may have to consider when using guide chains with FiberFX: if you plan to apply motion blur in compositing, you may find the motion data for 'long hair' animated with guide chains is corrupted. I think this is a bug because the data seems fine if you render only surfaced based fibers.

If you run into this problem, the workaround is to use the Polygonize command to make a mesh of the fibers, do the motion data pass separately, and feed that data into the vector blur tool in your compositing program as an alternative vector source. If you're curious, the full process is explained in this thread: http://forums.newtek.com/showthread.php?t=127311&highlight=fiberfx

Hopefully there's a fix coming because this above workaround is a lot of extra work and the result might not always be good enough.

Of course, if you're rendering motion blur 'in-camera' you can disregard the above.

Hope this helps.

G.