PDA

View Full Version : XFrog problem



adrian
04-18-2012, 08:21 AM
I'm trying to use an Xfrog plant but it's not rendering correctly in that most of it is transparent - anyone else had this issue?

rcallicotte
04-18-2012, 08:52 AM
Yes. Sometimes this works and sometimes not so well. What I have experienced is when I use a tree directly from xFrog it works, but it is made with the xFrog Tool it does have problems in LW. Not an expert at this, but I've heard using Clip Files for the Alpha works.

adrian
04-18-2012, 09:39 AM
Thanks for that, I'll give it a go. The ones I'm using are the free ones so I don't actually have access to XFrog itself so hopefully the clip map trick will work because they look awesome!

alexs3d
04-18-2012, 11:26 PM
maybe the leaf material is not double sided ?

OFF
04-18-2012, 11:42 PM
Select the trunk (all except the tree leaves), copy the UV map (Modeller/Map tab/Edit Maps/Copy Vertex Map). With a selected surface remove previous map.
The point is to remove the trunk from the list of polygons cut by Clip Map.

adrian
04-19-2012, 03:32 AM
Maybe I'm misunderstanding - I'm doing the following steps:

Load object
In Polygon statistics select Default_trunk_copy1 (the trunk surface)
Select Map tab
Edit maps --> Copy Vertax Map
Call it New Texture
Select the old UV texture --> Clear Map

But it's still not working - same result as screenshot above, most of the leaves transparent.

If I try the above steps with the leaves as well I get no transparency at all.

To answer an earlier question, yes all surfaces are set to double-sided. I also downloaded the LWO version from the Xfrog site.

OFF
04-19-2012, 04:03 AM
Clear Map from Trunk surface! But leave it on the leaves!
Leaves = Texture N1.
Trunk = Texture N2.
In Surface Editor and Render/Clip Map editor correct your settings.

adrian
04-19-2012, 04:57 AM
Doesn't work.

I'm so glad they made these free ones available because I would be so p****d off if I had spent $199 on a library of these only to find most of them are next to useless.

Even tried separating the trunk/branches and saving as a separate object but that doesn't work either because the transparency is screwed on the leaves as well.

Funny thing is, a few of them do work without any fiddling about.

D-Lab
04-19-2012, 05:09 AM
Hi,

Can you tell us what is the plant that's causing problems so we can try ?

Tchao

D-Lab
04-19-2012, 08:08 AM
Ok, it's a ray recursion limit problem, just increase it in the render globals panel.

A more effective way would be using clip map instead of mapping transparency channel.

Tchao

adrian
04-19-2012, 08:15 AM
Sure, it's this gorgeous looking fern here:

http://xfrog.com/product/X-44.html

Click on free download to the right - I chose the LWO version

The one I'm trying is the object called EU48_6.lwo
(http://xfrog.com/product/EU48.html)

and it's the tall one.

I do hope it's something I'm doing wrong.

adrian
04-19-2012, 08:21 AM
Ok, it's a ray recursion limit problem, just increase it in the render globals panel.

A more effective way would be using clip map instead of mapping transparency channel.

Tchao

OMG YES!!!! It was originally set at 6, so I upped it to 20 - more was rendered but still not perfect, so I upped it again to 50 and voila, a perfectly rendered fern without changing any of the textures.

Thanks - would never have thought of that! I guess now I need to learn what ray recursion limit is, and what the optimal level is.

I stand corrected Xfrog, your products are great :thumbsup:

kopperdrake
04-19-2012, 05:33 PM
Seriously, as D-Lab suggests, copy your transparency settings from the surface panel (then untick them so there's no transparency applied in the surface panel) and paste them into the clip map channel of the object you want the transparency applies to. High ray recursions will mean high render times, and you will still run into trouble with very complex scenes if relying on the surface setting transparency rather than clip maps.

When I get an Xfrog tree, I put the solid objects (trunks, twigs etc) into one layer, and each leaf type that uses a different leaf image into their own layers. That way I can apply the correct clip map image to each object, and turn off the transparency in surface settings.

adrian
04-20-2012, 03:06 AM
Absolutely - doing the above is fine if I only have one fern in the scene but any more will be prohibitely expensive render time wise.

I think I was misunderstanding the process because what I was doing yesterday definately wasn't working. I just tried the clipmap trick and this worked fine and of course much quicker :thumbsup:

kopperdrake
04-20-2012, 04:41 AM
Cool :)

It's worth keeping the clip map layers in the transparency settings in the surfacing panel, just unticked. That way, when you next bring the object into another scene in the future, you can just copy and paste the layer from the object's transparency settings in the surface panel, to the object's clip map channel for the new scene.

:)