PDA

View Full Version : Stopping Bullet



Philbert
03-19-2012, 04:27 PM
My first experiment, with Bullet, I have some coins that I'm dropping into a box (actually a coin hopper) and they drop in fine, but they never stop bouncing around. I've tried turning Bounciness all the way down and even off, The deactivation time is the default 1 second. What am I missing? Thanks.

Philbert
03-19-2012, 09:13 PM
Solved after playing with the Collision Margin. It would help if you could somehow see that margin as a dotted line or something.

BennyB
03-19-2012, 09:14 PM
Have you looked at Lightwave 11 Trial Content Bullet_Tests folder. Lots of examples with things stopping just fine.

Trial content download is here:
http://www.newtek.com/products/lightwave/lightwave-downloads.html

Philbert
03-19-2012, 09:15 PM
I know it can stop, the question was how, and I solved it above.

BennyB
03-19-2012, 09:25 PM
Great. Thank you for posting The solution to your problem. Might help someone in the future.

Philbert
03-19-2012, 09:27 PM
Actually I'm not sure it's solved now. it worked with my start of just 8 coins, but when I added more the problem started up again.

Video:
http://screencast.com/t/0s3Y5duyQD

Surrealist.
03-19-2012, 11:09 PM
Is there a quality setting?

Philbert
03-19-2012, 11:46 PM
I can't find anythign that looks like quality, unless it's got a different name.

Surrealist.
03-20-2012, 12:55 AM
This might Help.

In the activation tab:


Deactivation Time (s) - This allows you to control when dynamic items are set to rest
by Bullet Measured in seconds, this value sets how long a dynamic itemís linear or
rotational speed has to be under the threshold settings, before they are then put to
sleep by Bullet This helps control any jittering of items near the end of a simulation
Sleeping items will naturally be awoken if they are disturbed by any further collisions


In the World Tab:


Dynamics Framerate (fps) - Set the frames per second for dynamics calculations By default
this is at 180 fps Decreasing the value will result in faster calculation times at the expense of
simulation accuracy (objects penetrating each other) Increasing will result in the opposite,
more accurate simulation, but with slower calculation times

Basically the quality setting.

Between those two you should get it going. With one cube I set the quality to 1000 to stop it from jittering. You can play with these settings in your scene to see what works.

Philbert
03-20-2012, 12:59 AM
Well the Deactivation Time doesn't seem to do anything. The default is 1 Second, but I also tried 0.5 seconds and either way 3 or 4 seconds in they were still flopping around like a fish out of water. I tried increasing the FPS to 1300. It calculated slower and the pieces move around individually less, but they flop around as a group now. Thanks anyway.

Surrealist.
03-20-2012, 01:49 AM
Well that's too bad because those are the only settings I can find.

Did you have a look at the sample files?

Philbert
03-20-2012, 02:08 AM
Well I looked at some, there were too many to go through them all right now.

Skonk
03-20-2012, 02:39 AM
How big are the coins?

Pretty sure it doesn't play nice with very small or very large objects (so with items that are small in the real world they may need to me made a little bigger than "to scale").

You could fake it btw by using an envelope on the "Time Scale" so that as all the coins drop in you take the time scale down to 0 which will effectively stop all the bullet calculations.

From my limited tests I was also unable to make items totally stop (in a way that looked nice) even on simpler scenes than yours, the only way I managed it was to animate the time scale to quickly stop bullet moving the objects once they were about where I wanted them.

I tried changing the deactivation time and the linear/rotational speed settings, from tiny values right through to huge values and it honestly felt like they did absolutely nothing.

Philbert
03-20-2012, 03:26 AM
The objects are small but I read about that in the manual and tried making them bigger with no luck. I worked around the simulation now and did something else but I'll keep the Time Scale in mind. Thanks.