PDA

View Full Version : Hypervoxel problems



dragonchild00
03-12-2012, 03:20 PM
Im not sure if this is a bug or if I am doing something wrong. I work in the oil and gas industry and I have a scene that will be underwater and will require particles. When the scene is rendered, having hypervoxels turned on causes the textures to "dance" or jitter. It took me a while to figure out that it was the hypervoxels causing this problem, but I still don't know why. I have attached two videos showing the difference. For obvious reasons I can't show the real equipment, but have replaced it with simple stand in objects. But the problem still remains the same. Any help would be great.

fgreen
03-13-2012, 08:31 AM
My first thought was that it looks like some kind of video compression artifact. Have you tried to render to non-compressed stills?

Another possibility may be the surfacing and/or a radiosity issue-- like the surfaces are picking up and reflecting the motion of the particles.

Are you using radiosity? If so, I'd try a render with it off.

I would also try simple non-reflective surfaces on all the objects to see if it is some kind of wierd reflection.

dragonchild00
03-13-2012, 12:42 PM
Thanks for your response. The problem happens with or without radiosity. And in the videos I made when I noticed the problem, I rendered them without compression. I will try the simple non reflective surfaces and see if that makes a difference. It would be a shame if I can't use reflections because of hypervoxels. But so far I have been rendering them separately.

dwburman
03-13-2012, 04:15 PM
That is strange. You could try toggling some of the render and shadow flags, but I don't know what exactly is going on there.

Do you still get the flickering when you set the HVs to UnSeen by Camera? Does it flicker if you uncheck Cast Shadows?

prometheus
03-16-2012, 01:14 PM
might be reflections too from the reflective hvs, but I guess it might guess shadow raytracing.

You could try render out the hvs only in a second pass and composite if you can?


Michael

inkpen3d
03-17-2012, 11:46 AM
If you have shadow noise reduction turned on, try turning it off. I have a vague recollection of this causing noisy rendering of HVs.

Regards,
Peter

dragonchild00
03-27-2012, 09:45 AM
Sorry for the slow response. I have tried a number of things now. I have turned off all the shadow functions for the hypervoxels, and also disabled the noise reduction. Neither one of these stop the problem. I have now turned off raytrace reflections to see if that makes a difference. Will post when its done.

stiff paper
03-27-2012, 10:07 AM
My brain hurts through trying to remember, and I'm still not completely certain, but...

I think that's a very old bug. In fact, my brain is telling me that's definitely a very old bug, but it's refusing to tell me why it thinks that or where it heard that. So I'll have to go with I think...

If you have any procedural textures on the foreground box, the bug my brain thinks it remembers is that sometimes HVs can cause a procedural texture to animate for no reason.

Try removing the procedural texture and doing a test render.

dragonchild00
03-27-2012, 11:47 AM
That could be the problem because the objects do have procedural textures. But I need them to stay on there. So far, turning off raytrace reflections is doing the trick. So it may be a combination of the reflections and the procedural textures. I was rendering my hypervoxels in separate layers, but for a couple scenes, I need them to pass thru a machine. Thanks for all the help guys.

bazsa73
03-27-2012, 12:06 PM
Evil bug for sure! You must render separately with all object set as black matte except the HVs then an object only pass.

Mr Rid
03-27-2012, 05:47 PM
Reminds of problem I had recently where Amb Occ nodes were not working well with sprites in the scene.