PDA

View Full Version : unwanted camera shake (space scene)



aSkeptic
03-11-2012, 08:01 AM
Hi Lwavers,

I am making a space scene with a ship and the planet earth (not to scale). The planet is very large and the ship is very small. I've got one camera that orbits the planet with the ship and this is working great. The camera is parented to a center null at Earth's center. The ship is parented to the camera. This camera works just fine. But if I parent a new camera to the ship I get problems. The whole scene appears to shake violently. I've tried changing grid sizes and that didn't work. :help:

Thanks in advance

evenflcw
03-11-2012, 09:32 AM
Is everything done in real world scale? Then perhaps you are seeing floating point precision errors. Because the scene is so big, the numbers have so many digits they can't fit in memory, so you lose precision. You need to to scale things (the relative proportions) down so the big is not so big in relation to the small! Apparently most 3d softwares still struggle with this.

PS. Could you upload the scene? (replace objects with nulls)

aSkeptic
03-11-2012, 09:47 AM
Is everything done in real world scale? Then perhaps you are seeing floating point precision errors. Because the scene is so big, the numbers have so many digits they can't fit in memory, so you lose precision. You need to to scale things (the relative proportions) down so the big is not so big in relation to the small! Apparently most 3d softwares still struggle with this.

PS. Could you upload the scene? (replace objects with nulls)

Thanks for the reply.

Yeah I suspected something similar.. I was hoping for a super easy solution of course :)

shrox
03-11-2012, 02:15 PM
The camera and light icons will often look messed up too when you get too far from the origin.