View Full Version : Instancing causes a system hang

02-28-2012, 05:50 AM
I have a scene with a reasonable amount of instancing in it, say 600 clones of simple human silhouettes, just flat polys, nothing too taxing. Whenever I try to alter the size of the instances using the random setting it causes the whole computer to freeze, even ctrl - alt - del doesnt work. I removed the resizing (after an exhausting step by step process) and fixed the crash.

All was well, or so i thought because then the same error again. The system started to freeze on the third radiosity pass of a scene with three motion blur passes (again tedious to work this out). Then it was happy again for a while when I turned off the multiple passes... Now itthe system is hanging again but I haven't worked out why...

Is there some funny setting I am missing or it instancing buggy like this for others?

02-29-2012, 04:40 AM
You just canīt expect answers if you donīt tell what lightwave version and system you are using.

and what instancing? dp instance? hd instance or lightwave 11 native instancing?


02-29-2012, 06:54 PM
Yeah sorry. Not much sleep with these render issues.
Lw11 native instancing 64 bit
Win7 pro 64 bit
16gb ram
Dual Xeon 5410

Sorry again...

02-29-2012, 08:47 PM
Not much help I know, but we have been using the new LW11 instancing without difficulties at all. Same specs. LW11, Win 7 64 only 4GB ram.

We use the random rotation, random size on trees, those trees have 1,000 plus polys each. And we are instancing it more than a 1,000 times. No issues, realtime movement of the rotations and sizes.

Again, I know it's not help, but it does tell you that it may be something else on your end.

Stick of ram going bad? Try remaking the polys your using? Good luck...keep us posted.

02-29-2012, 09:06 PM
if your scene doesn't have objects you can't share, feel free to upload and I'll test on my system. Just a thought.

02-29-2012, 09:17 PM
Is this an instancing issue or is this an issue with your textures and transparency calculations? These "simple human silhouettes" all have transparency?
Are you trying to resize instances of simple polys then resizing the textures to fit?
Have you tried versions of your texture with no transparency? (Black and white)

Just throwing some ideas out there.

03-01-2012, 03:31 AM
Thanks fOr the suggestions. I tried redoing the geometry and removing the transparency to no avail. There is no real texture to resize they are just Matt black. I altered every parameter one by one until I found the cause and it was the size adjustment. Turn it on it crashes turn it off it doesn't. I got around it my manually randomly sizing the clone bases. I had to finish the job by yesterday so I just had to work around each issue. Interesting nobody else has any issues though. Project was confidential but I might make a generic copy and see if I can replicate the issue in a new scene.

03-01-2012, 07:14 AM
Yeah it is strange what can happen.

It would be a good idea to see if you can repeat it and upload a file for others to take a look at and see if they can confirm. If it is consistent then send in a bug report.

03-04-2012, 05:01 PM
Thanks for your help everyone. I have gone back to try to replicate the problem and - guess what? That's right, now that I don't have a pressing deadline its working perfectly - same scene, same objects same everything, no hang...