PDA

View Full Version : where are my lw preferences?



dlanimation
02-06-2012, 10:39 AM
i cant seem to find my lw9 modeler and lightwave prefs..
what is the path? are they hidden?

thanks
dl

rsfd
02-06-2012, 11:20 AM
depends a bit what specific file you are looking for:

~/Library/Preferences/
{files: com.newtek.LightWave.Hub.plist, com.newtek.LightWave.Layout.plist, com.newtek.LightWave.Modeler.plist, com.newtek.Valkyrie.plist, LightWave3D/lwpc_edgebevel.cfg, LightWave3D/RounderConfigs.txt}

~/Library/Preferences/LightWave3D
{the whole folder}

~/Library/Application Support/LightWave3D
{whole folder}

these would be the default paths.

The User Library is hidden by default under Lion, the easiest way to access would be:

Finder > open "Go To" Menu > hit "alt"


{a more permanent approach would be to use the Terminal:

chflags nohidden ~/Library
to revert to Lion default:

chflags hidden ~/Library}

dlanimation
02-06-2012, 01:52 PM
when i launch lw 9.6 on 10.7.2 new laptop the migrated side has my old prefs...the new side does not ,i want to copy my old prefs to new side of lap top...so.. ,where/how to do that?
thanks
dl

rsfd
02-06-2012, 04:07 PM
sorry, I'm not sure if I understand correctly:
did you use the Migration Assistant to migrate your files from an older Mac onto a new MBP? And you created a New User Account (with a different name) on that MBP?

If you created a new User account with a different name ("the new side"?) on the MBP, you will most likely run into Privileges issues, when copying files from one User Account to a new (with the different name). You then need to set your new user as Owner for the "old" files.
There are different ways to bring files from one User account to another:
- Use the Public folder of the receiving User
- or the Shared User folder (For all users)
- copy files onto an external media (USB thumb drive e.g.) and then to receiving User

If you have the files in the correct locations, check/correct Owner:
- on folders:
select folder > cmd-i > Privileges
OSX most likely notes your "old User" as Owner
if your "new" user isn't listed
click on the "+" and add your "new User" to the list of Users
then set this user as "Owner" and verify it has "read/write" privileges. (the pop-down menu with the gear icon)

You will have to enter your Administrator password.
choose "set changes for all containing files"
(don't know exactly, what it is called {non-US system here}, but I think you get the idea)
this applies the changes to all files within the folder

for single files you need to set the new user as Owner individually.

A different approach:
If you launch LW within your "new" account, it creates default prefs (Modeler, Hub, Layout aso) which will have correct privileges.
You then could open your "old individual prefs" in e.g. TextEdit, copy the content to the clipboard and paste it in the appropriate "new" prefs file.
Then, you don't need to mess around with the Privileges at all. Just save the file with the new content, keeping its "plain text" flavour.

3dworks
02-06-2012, 05:38 PM
not fiddling around yet with osx lion here... also, i learned to stay away from the migration assistant: i had nothing but all sort of little issues, and the time to solve them was nearly always more than if i had setup all those applications and settings manually.

back to the topic: another tip for resolving your issue is to create a 'Preferences' folder within the lightwave application folder. modeler and layout will both use this before using anything in the 'user' directories. this is also working for LW10 and LW11, btw.

what you are experiencing is that lion hides certain system files/folders to the user, imo a step back towards the way windows always did, assuming a user is stupid enough to delete those vital files. the result is however that from a practical point of view most users will have to look into those areas when taking care of the installation of new apps or when solving issues with them. but fortunately, there are several free little customisation helpers around for lion which can help you to revert 10.7.x to something more 'usable', including making visible again those folders.

hope that helps

markus

brunopeixoto
02-07-2012, 12:02 AM
Just press the option button when selecting , in finder, on the go menu - library

dlanimation
02-07-2012, 03:28 PM
i know where my prefs are ..i just dont see them..
how ,exactly do i unhide them? option, when selecting didnt do anything,what am i doing wrong?
thanks
dl

rsfd
02-08-2012, 03:42 AM
what OS are you running?
for Lion: please re-read posting #2

LW preferences files are not hidden (unless *you* have set them to be hidden).

If you never have launched LW on your new machine, you won't have preferences.
LW 9 generates the default preferences files on first application launch.

If you want your preferences in another location than the default ones, please re-read posting #5.

As you aren't giving exact informations, there is not much more to do for us here…

dlanimation
02-08-2012, 02:22 PM
i have os 10.5.8. on one mac mini (is a b.u. of my desktop also 10.5.8.)
and 10.7.2 on a new laptop.
i migrated from the mini to the laptop..
i thought my prefs were in HD/library/prefs..
but i dont see them there..
when i launch lw9.6 on the migrated side it remembers all my prefs.
when i launch on they unmigrated side .it has default prefs..not mine..want t o get my good prefs to new side of laptop.
thanks for your patience.
dl

rsfd
02-09-2012, 03:33 AM
ah, I see…
There are at least 3 Library Folders under OSX:
HD/Library
HD/System/Library
HD/Users/"Your User Account"/Library

(If you run multiple User Accounts on one machine, each User has its own Library Folder with its own data).

In this case here, you aren't using your User Account's Library folder, which would be the more correct place to store the preferences.
The tilde (~) is used in paths as a shortcut for the User's Home Directory.

So you should find your preferences under Lion at:
"Your User Account's Home Directory"/Library/Application Support/LightWave3D and
"Your User Account's Home Directory"/Library/Preferences
(more info in posting #2)

As also I mentioned earlier, the User's Library Folder under OSX Lion is hidden by default.
Easiest way to access: Finder > "Go To" Menu > "alt" key (more: posting #2)

And if your User Account on the Lion-MBP has a different name than on your Mac mini, you will most likely encounter issues with Privileges when just dragging them to the new Account while using the "Shared" or "Public" Folders.
I would suggest the "Copy/Paste" route to circumvent this (see posting #4).

Hope, this helps a bit.
If you have further questions, feel free to post here…

dlanimation
02-09-2012, 10:36 AM
got it..thanks
dl

rsfd
02-09-2012, 12:20 PM
you're welcome :beerchug: