PDA

View Full Version : How to remove/add to a UV map? (overlapping issue)



Algae998
01-24-2012, 08:48 PM
Hey all,

Im working on unwrapping a building and Im having an overlapping issue.
Heres what I did:

When I first made the uv map, the A-frame of the building was broken up into smaller pieces around the uv space. I wanted to regroup them.
I selected the entire A-frame area, hit "clear map" to remove it from the uv area and then recreated uvs for those polygons (basic atlas) into the original map (so theyd be grouped together).
Once I moved them into place the way I wanted in the uv texture screen, I made sure to make everything the same surface and attached the uv map to the surface. I then exported the model to Zbrush.
In Zbrush, I hit "new from uv-check" (to show the uv map and check for overlapping polys) and there are big triangles spanning from the right side of the map, merging at the top left (see pic).

This only happened after I removed and added the a-frame to the uv map. Everything looks fine and all polygons seem to be accounted for in LW.
Did I mess something up with the uv points?

Little bit stumped so any suggestions would be great!

zardoz
01-25-2012, 05:02 AM
usually before this happening you have to unweld all points, cut the geometry, clear the uv, paste back the geometry and then weld points again. Try if this solves your problem.

Algae998
01-25-2012, 10:27 AM
usually before this happening you have to unweld all points, cut the geometry, clear the uv, paste back the geometry and then weld points again. Try if this solves your problem.

It looks like that solved the problem :D
I had a feeling I was missing a step, thanks.

probiner
01-25-2012, 10:32 AM
Scorpion Wins!

Ryan Roye
01-25-2012, 04:34 PM
Scorpion Wins!

Technicality!

jasonwestmas
01-25-2012, 07:01 PM
Shouldn't have to be that way but I never had a UV problem I couldn't solve in modeler. Just a matter of time :D

Algae998
01-25-2012, 09:42 PM
Scorpion Wins!

:D



That did correct the problem. It was a matter of not unwelding the points before removing/adding the geometry to the UVs, so the points were stretching and going whacky.

cptwhite
01-31-2012, 03:51 AM
Here's a few notes I made for myself (help for a newbie to applying UV ;) )

The basic method, a few simple steps::
We can have multiple materials all using the same UV map, but using a different texture. Or we can have the same UV map AND the same texture map (with different materials looking at different areas of the texture map).

Basically the UV is a property of the MODEL and only needs applying once. The texture is a property of surface you apply to the model. You can have multiple copies of the original model (so they bring with them the UV details). Every copy is then given it’s own surface (panel 1, panel 2 etc.) and the relevant texture applied per surface. This is true whether that is a separate texture file, or a different area of the same texture file (i.e. as done on TBP textures to maximise texture map space).

Tip for when laying out a manual UV map:
Whenever you have a group polygons selected on the UV map, CUT and PASTE back in so surrounding polygons on the model won’t be stretched when you are stretching/resizing them on the UV map. This is separating the vertices.

Set texture resolution:

In modeller
Edit > Display Options > ‘Backdrop’ tab > Image Resolution = 1024 (for UV Texture window)
Edit > Display Options > ‘Layout’ tab > Image Resolution = 1024 (for 3D window only)

In renderer
Edit > OpenGL Options > OpenGL textures (ticked) = 1024 x 1024

Starting a new UV map / Editing an existing UV map:

Note: Editing an existing UV map is done in two ways depending if you have ticked ‘initial value’ (automatic map option). Normally we would be working with a manually created UV map and editing it by selecting the UV map we’re working on (listed in bottom right of screen) and using lightwave’s standard move/rotate/stretch/polygon select lasso tools to manually select and arrange the polygons on the UV map.

In modeller
‘Map’ tab > ‘New UV Map’ button (also for editing an auto-generated existing map – where ‘initial value’ is ticked …select existing map from pull down list)

1. Choose a name for the UV (e.g. Swoopcan_UV)
2. Uncheck ‘initial value’ so we’re creating a manual UV map
3. Click ‘Create’ (this will make a map with the name specified, but it will be blank until we manually apply polygons to the map)
4. We will now select the polygons we want to apply to the UV map. See Polygon selection tools below to help with this
5. With the polygons selected click ‘Make UVs’ – choose the most appropriate ‘map type’ and ‘axis’ (manual alignment settings may be required, depending on the model).
6. Click ‘Create’ (selected poly will now appear on the UV map)
7. If applying multiple groups of polygons onto one UV map then resize/stretch/reposition the current group onto the map to where it should be (to make space for the other maps).
8. Repeat steps 5 to 7 for all the groups of polygons you want represented on the UV map until it is complete
9. Note UV maps should always be square; make sure your textures are as well (512x512 etc.)
10. Go to the surface editor and select the material/surface you are going to apply the texture too (note: select polygons and hit ‘q’ to create surface first, you’d do this if the model has more than one material type)
11. Apply the UV map and texture on the ‘Colour’ channel (click T next to colour)
12. If the texture map is already painted the polygons should have the surface properties and texture applied

Clearing a UV amp:
Note this isn’t deleting the UV map (see below) it is just erasing all UV data applied to the map (i.e. a rubber)

In modeller:
Select polygons to be erased from UV map > Clear Map

Deleting an existing UV map:

In modeller
‘Map’ Tab > ‘Edit Maps’ button> Delete Vertex Map
This will delete the currently selected UV map (shown in bottom right of the screen)