PDA

View Full Version : Need help! Problems with shadows (i'm new with LIGHTWAVE!)



ruejos
10-18-2003, 12:27 PM
i'm having problems rendering in layout. i have set up a scene with objects including lighting and camera.............but the lights just pass through my objects (all light types...sigh!), i have set the shadows on and followed every instruction from the manual - but it doesn't render and shadows when i hit F9 (sucks!).

Thanks in advance for the tips you'll be posting.

Ruel :confused:

Aegis
10-18-2003, 12:44 PM
Go to Rendering/Render Options and turn on "Ray Trace Shadows" - that should get your shadows. LightWave can cast two type of shadow - Ray-Traced and Shadow-Mapped. Shadow-Mapped do not require raytracing but can only be used from spotlights - you'll have to change the shadow type on the "Shadows" tab for the spotlight.

ruejos
10-20-2003, 11:43 AM
Originally posted by Aegis
Go to Rendering/Render Options and turn on "Ray Trace Shadows" - that should get your shadows. LightWave can cast two type of shadow - Ray-Traced and Shadow-Mapped. Shadow-Mapped do not require raytracing but can only be used from spotlights - you'll have to change the shadow type on the "Shadows" tab for the spotlight.

I just tried the instruction you've gave but it still doesn't work!

Attached herewith is a sample of the render.

Thanks.

Aegis
10-20-2003, 12:48 PM
Umm... OK... :)

The picture you've uploaded looks like it's only lit with ambient lighting (Light Properties/Global Illumination/Ambient Intensity) - this usually defaults to 25% and many LightWave users turn it off (0%) altogether 'cause all it really does is brighten your image (can be useful for lightening shadows though and it does play a part in Radiosity renderings but we'll save that for later ;)).

Your objects do not appear to be receiving any directional light in this image - no specular highlights, diffuse variation - nothing. Try loading LightWave, load your object(s) (not a scene), enabling "Ray-Trace Shadows" and hit F9 to render - by default LightWave has a ray-traced distant light at 100% and ambient at 25% - you should (hopefully) see your shadows then...

ruejos
10-21-2003, 12:01 PM
Originally posted by Aegis
Umm... OK... :)

The picture you've uploaded looks like it's only lit with ambient lighting (Light Properties/Global Illumination/Ambient Intensity) - this usually defaults to 25% and many LightWave users turn it off (0%) altogether 'cause all it really does is brighten your image (can be useful for lightening shadows though and it does play a part in Radiosity renderings but we'll save that for later ;)).

Your objects do not appear to be receiving any directional light in this image - no specular highlights, diffuse variation - nothing. Try loading LightWave, load your object(s) (not a scene), enabling "Ray-Trace Shadows" and hit F9 to render - by default LightWave has a ray-traced distant light at 100% and ambient at 25% - you should (hopefully) see your shadows then...

Thanks for the Advise you have provided and it helps me a lot! one should turn on ray tracing first before playing with the lights. I got that in mind now.

Hoping to here from you if i have problems arising from my training. Actually i am just teaching the software myself, lightwave course here in manila, philippines is very expensive - lucky i have found out this community that gives tips, tricks and advise to lightwave newbie like me!

Again thank you very much.....

Ruel

p.s. attached is part of the sample of my self training.

Aegis
10-22-2003, 07:09 AM
You might want to check out www.3dbuzz.com - they've got a number of free video tutorials available for download including a series on LightWave basics - good stuff to get you up and running. They're compressed with WinRar so you'll need to download the evaluation version from http://www.rarlabs.com/download.htm also you'll need the DivX codec from www.divx.com

Good luck! Feel free to ask questions!