PDA

View Full Version : skin material issue



nicolashe
01-11-2012, 07:02 AM
Hi,
I have no idea why after using skin material the object look amazing in VPR but when I render I get areas of dark around the object...

Any ideas why could be this huge discrepancy between VPR and the actual render?

RebelHill
01-11-2012, 07:08 AM
could be a few things, tracing options, ray recursions... VPR doesnt always trace everything that the full renderer does (plus theres draft and non draft mode differences in vpr).

For full answers... post your object/scene.

nicolashe
01-11-2012, 07:16 AM
Thanks but I don't think that's the only issue here. I found out that the Skin shader is taking way toomuch information from the object behind making it almost half transparent...hence the dark area. Again I have no idea how to decrease the amount of transparency in the skin shader as Newtek help on new shader ( and some old one) is virtually non existent. Any ideas will be appreciated.

RebelHill
01-11-2012, 07:24 AM
ok... well that sounds clearly like your scattering distance is set too high, allowing light to penetrate right through the object.

Its generally best to keep your model (and thus surface shader settings) at real world scale... also the new skin node is designed to work best with the new colourspace workflow introduced in 10x... using cs disabled will give porer results.

There've been a couple threads recently, do a forum search for skin/skin material/etc. Lots of info to be found.

nicolashe
01-11-2012, 07:29 AM
I thought so too...but I did check on the scale of the model and the scale of the scattering. I will continue to try and if I find the solution I will postit.

RebelHill
01-11-2012, 07:43 AM
also note its the scale of the model as it appears in modeller... if youve scaled it in layout, that has no effect on the surface scale settings.

nicolashe
01-11-2012, 07:55 AM
Yes, absolutely. The model itself is rather small...around 10 mm and the scattering i placed between 0.5mm to 0.3 but it really doesn't matter the background still comes from behind. I know is difficult without the object. But I really cannot share them. What it really gets me is that it looks beautifull on VPR but terrible in the render. T_T

lardbros
01-11-2012, 08:35 AM
Could be because your object is 'open'?

If you're model isn't closed geometry it won't work properly. Might seem annoying, but it makes sense I guess... as our skin is a fully enclosed entity. :D

Also, make sure you don't have 'exclude from vstack' ticked in your surface, and that your tracing options are on in the render panel. Also, double-sided can cause issues.

Sensei
01-11-2012, 12:35 PM
Isn't VPR not supporting preprocessing nodes?

nicolashe
01-18-2012, 01:01 AM
Hi guys. Sorry for the late answer. Effectively the problem was that "exclude from vstack" was checked. A quick search about both vstack and the skin material in the help revealed nothing. LW should definitely improve it's documentation. It used to be exemplar in the past versions.

evolross
01-23-2012, 10:46 AM
Isn't VPR not supporting preprocessing nodes?
Yes, but the new "Skin" shader node was designed specifically to work in VPR. So I assume it either doesn't have any preprocessing or they've figured out a way to make it work for this node.