View Full Version : How to repair a corrupted LWO ?

11-27-2011, 08:13 AM
I can't load a lwo. The modler show me the message : "Error reading file"
I have work hard on this object.
How to repair this object ?
There are a plugin or program to repair the corrupted lightwave objects ?

11-27-2011, 08:20 AM
You can check your windows TEMP files for backups. Sometimes you can find older versions of models there. I don't think there is a plugin or a way to repair broken lwo files.

11-27-2011, 08:42 AM
My temp directory is empty...

11-27-2011, 08:47 AM
I can't configure the auto backup / save in the hub interface.

11-27-2011, 08:55 AM
It does it kind of automatically. I haven't configured the auto save option but still after a few months the are some lwo's left behind. Don't know why that happens but it does ;)

11-27-2011, 09:09 AM
If you are using LightWave 10 a backup directory is created automatically in your content directory if you have set it in Options.


11-27-2011, 11:23 AM
My backup option were on "never".
I re-model my object...

11-27-2011, 11:27 AM
Sorry man.

Save often (CTL-s) and I would also suggest saving versions (Shift-S). Good file practices always seem to come from learning the hard way. I think most of us have been where you are now. Now you will get in the habit of better habits with regards to saving your project.

But I wonder if you have learned the lesson about backing up your hard drives?:devil:

11-27-2011, 12:36 PM
If you've been running the hub and working between LW and Modeler, there MIGHT be a temp copy on your HDD. When the server we were using in the studio I worked at crapped out and took a pile of assets with it, it was the GB's of crap that had collected on the hard drive via the hub that saved our butts... It was a huge collection of "swap" files where the hub would write and transfer between the two app's... :)

I think its (on Windows) somewhere in documents & settings. From a troll online, should find it somewhere in this kinda area:

Application data/Local/Temp/lwhub

You'll probably have to list by date and grab the latest file. Well, that's if its even there (it may not be)

11-27-2011, 09:54 PM
try to open it with previous version, 3d exploration even blender o max.

11-28-2011, 12:48 AM
I had a similar problem and I opened it in Modo and saved later


11-28-2011, 01:56 AM
Many thanks for your answer,
I trying to open my file in a hex editor, and it seem that the lwo are full of "00".
I have trying also with modo, but it don't open the file.
I have lost my data...
Thanks for help.

11-28-2011, 03:57 AM
Ouch - I feel your pain.

My saved object iterations regularly go over v100 with shift-s - having lost stuff in the past I am paranoid, and I absolutely hate modelling the same thing twice.

10-12-2014, 10:34 AM
I had a similar problem and I opened it in Modo and saved later


Thanks, you saved me 1 hour of hard work!

After using "ctrl-c" to copy one layer, Modeler crashed (11.6.1 on OSX) an it corrupted the file. My last version was an 1 hour before. The good point it's the first time it happened since I use LW (I started in version 7.5, I think 10 years ago.)

10-12-2014, 12:41 PM
I'm surprised it corrupted it at all: TMK the file is just sucked into RAM and worked on there, it's not like it's interactive w/its instantiation on disk.

I blame Apple.

10-12-2014, 11:11 PM