PDA

View Full Version : EPS files do not import



K-Dawg
08-20-2011, 02:15 PM
Hi,

I'm having problems with importing EPS files into Modeler.

Each time I create a vector graphic and save as EPS and want to import it to LW nothing happens. I mean nothing. No error message, no object no nothing.

I have an example file attached, could someone please confirm if this is not only me? I need the EPS importer to work but it isn't.

Greetz

stiff paper
08-20-2011, 02:29 PM
I have an example file attached
Umm... repost your file?

K-Dawg
08-20-2011, 02:36 PM
Oops, my bad. I didn't see that .eps is an invalid file for attachments.

Sorry

prometheus
08-20-2011, 02:48 PM
You canīt save out eps format in the newer file format from 9 and up, open up the eps file in illustrator and save it in Illustrator 8 format.

It works here If you do that.

Michael

K-Dawg
08-20-2011, 03:09 PM
The thing is I don't have Illustrator anymore. Windows 7 doesn't run my Illustrator 10 so I have to use Inkscape.

When I export in Inkscape I can choose EPS 2 or EPS 3 to export. Which one should I do? I tried both but LW still doesn't import.

Any other Ideas? So the problem seems not to be Inkscape but rather LW's importer.

Greetz

prometheus
08-20-2011, 03:39 PM
The thing is I don't have Illustrator anymore. Windows 7 doesn't run my Illustrator 10 so I have to use Inkscape.

When I export in Inkscape I can choose EPS 2 or EPS 3 to export. Which one should I do? I tried both but LW still doesn't import.

Any other Ideas? So the problem seems not to be Inkscape but rather LW's importer.

Greetz


write to newtek and complain that they should update old things, and in this case the eps loader wich hasnīt gotten any attention for years.

otherwise try demo versions of different programs that can handle eps files, but they need to be able to export out to older eps formats, otherwise your stuck anyway.

you might find a way to import the eps file in to another 3d software and save out as lwo if that is an export option for that 3d software.

Michael

prometheus
08-20-2011, 03:45 PM
truespace is a free 3d program, imports eps files ..and you might be able to export to 3ds or dxf format and load in to lightwave..
just a long shot, donīt know if true space would have any trouble too..or if the export from truespace to 3ds and then to lightwave would be nice or not.

http://www.caligari.com/products/trueSpace/ts75/Brochure/specification.asp?Cate=BSpecification

Michael

K-Dawg
08-20-2011, 04:11 PM
Thanks for your Information.
I dunno how and where to contact Newtek for a report but you did help me.

My solution is not to use so many difficult ways or software and exports.
I just tried something and with your hints about different software, 3Ds etc I thought, since I'm using Inkscape and thats Opensource, maybe Blender has an EPS importer. Well not quit. I think since the 2.5 of Blender there is no straight eps importer anymore, but Blender has a SVG importer and the native file for Inkscape is SVG. Makes sense since SVG is a ISO Standard.

Never the less I could successfully import my Test as SVG, export as obj (too bad Blender only has a .lwo importer and no exporter anymore) and imported that into LW. Cleaned it up and am good to go from there. Nice thing is, the Import is really fine around the curves. Maybe not always the best, but will do for Logos in LW that are not Sub-D :)

Greetz and thx

safetyman
08-21-2011, 07:09 AM
In the meantime, I've opened and converted your file to an eps format that LW can import. Make sure you tick the "Auto Axis Drill" box on the import dialog.

dwburman
08-25-2011, 06:08 PM
Yeah, I filed a bug report about that problem to NT a while back and included several files that InkScape saved. LW should be updated to read those files if it's not too difficult. I'd also like to see SVG vector import.

prometheus
08-26-2011, 08:39 AM
It seems that luxology and Modo canīt get the importer to work either,
only the Illustrator 8 version working there too, ther must be a reason for this more than neglecting it?

The challenge...whoīs gonna be first to fix this...the old newtek team, or the new newtek team:D

Michael

K-Dawg
08-29-2011, 07:36 AM
Oh I totally forgot about this thread.

@safetyman
Thanks for converting, but I made that File so people here can test with it. I was using a different one for my project. Thanks anyway :)

@prometheus
I didn't know that with Modo, but thinking that Modo was made from some people who use to be at newtek I can understand that their importer is not working either. I doubt that is a common importer issue. Blender imports EPS with no problems, I'm sure other packages can Import without any issues too. I can't test others since I only have LW and Blender. The main reason I started to tinker with Blender was not cause of fluid but rather I can use Blender on my Linux machine and unfortunately I can't run LW on Linux :(

I was really looking forward to a native Linux version of LW.