PDA

View Full Version : Custom keyboard shortcuts don't appear as presets



macahuna
08-18-2011, 02:17 PM
Haven't had this problem until the latest upgrade, but my custom keyboard shortcuts don't show up in the Presets window, and they're not "sticky." Each time I fire Modeler up, I have to go through the keyboard shortcuts again.

I only have a few, but it's driving me nuts!

When I make all the changes I want, I click Save, and it applies a .cfg suffix. I can see it in its folder, but all I see in the Presets drop-down menu are Default, Studio something or other, and three LW versions - none of which suit my work style.

Am I missing something?

nickdigital
08-18-2011, 02:31 PM
I believe that's just saving out your shortcut settings to an external file. It has nothing to do with the actual LWM.cfg or LW.cfg file. The file you're saving is so you can load your settings onto another computer or version of LW.

macahuna
08-18-2011, 02:35 PM
Okay, I'll buy that argument, but how do I get them to "stick?"

Is there another panel that I'm missing?

Thanks!

nickdigital
08-18-2011, 02:39 PM
It should just be a matter of changing your shortcut mappings and then saving Layout or Modeler to get them to write to the actual config. Do you redirect your configs with the -c flag? Are you redirecting to the right place? When you close Modeler or Layout does the time stamp on the config actually change?

macahuna
08-18-2011, 02:44 PM
Hmm. I wouldn't know a config if it fell out of a tree on me! I usually save the files incrementally, and they show up in their folder with the correct time and date on them.

I just did that again, and closed LW. Upon firing up again, the shortcuts are there - but they were last week when I was working LW last, but I'd had to reconfigure them at the beginning of that session.

nickdigital
08-18-2011, 02:56 PM
Hmm. I wouldn't know a config if it fell out of a tree on me! I usually save the files incrementally, and they show up in their folder with the correct time and date on them.

Are you talking about the lwo or lws files? The cfg files aren't dependent on your lws file though there are some things in Layout that do get saved with the lws file (fps, etc). But shortcut mappings aren't I believe. Do a search for LW9.cfg or LW10.cfg (I don't know which version of LW you're using) to find where the files are being written to.


I just did that again, and closed LW. Upon firing up again, the shortcuts are there - but they were last week when I was working LW last, but I'd had to reconfigure them at the beginning of that session.

Maybe it's the computer gremlins.