PDA

View Full Version : Lightwave slowing down



skywalker113
08-08-2011, 01:13 PM
I am building a spaceship battle that is very heavy on polygons, textures, and particles.

Whats been slowing me down lately is waiting for the computer to respond whenever I change from layout to modeler, load scenes, switching layers, open folders, etc. Can anyone give some advice how to speed things up?

Im doing the best I can to reduce memory with proxy objects. But its still a heavy scene once I start making explosions. Along with hardfx.

I have divided the multi million poly starships in modeler, into multiple layers (like 40 layers). But still, it can take a while to switch between layers, or from windows.

prometheus
08-10-2011, 04:58 AM
I would try and finish as much as possible of the modeling inside of modeler as much as you can..

close modeler and work only with layout if possible.
Avoid to many layers..donīt think lightwave handles that to well.

and particles..deactivate,uncheck the particle emitters not currently being worked on...no use in having several thousand other particles slowing down if you work on another emitter.
You could easy activate all of them when the whole scene is setup, even so it could be render heavy and clog the system..meaning that you might wanīt to render different passes of different emitters.

Go through your hv settings and check what render cloggers there are..such as volume mode voxels, with full volumetric shadows, etc..
Be aware of how many particles you are using..

Michael

skywalker113
08-10-2011, 04:01 PM
thx for the tips. Although layout seems to crash constantly. Like every 2 minutes. Is there a solution to this?

Celshader
08-10-2011, 06:32 PM
I am building a spaceship battle that is very heavy on polygons, textures, and particles.

Whats been slowing me down lately is waiting for the computer to respond whenever I change from layout to modeler, load scenes, switching layers, open folders, etc. Can anyone give some advice how to speed things up?

Im doing the best I can to reduce memory with proxy objects. But its still a heavy scene once I start making explosions. Along with hardfx.

I have divided the multi million poly starships in modeler, into multiple layers (like 40 layers). But still, it can take a while to switch between layers, or from windows.

FWIW, I launch my LightWave 9.x from a Windows shortcut with "-0" in the shortcut. This disables the Hub. Otherwise Layout and Modeler are constantly keeping each other updated. This can slow LightWave down if you're dealing with a lot of data.

For LightWave 10.x, I launch Layout from a Windows shortcut with "-0 -i" in their Target paths. The "-0" disables the Hub, while "-i" stops Layout from monitoring the disk to make sure it has the latest version of the object loaded into the scene.

For particles, launch the FX_Browser, click on "Option" and set the UpdateMode to "user." This means particles will only update when the UpdateMode is restored to "auto" or when a calculation is run (FX_Start/Calculate/FX_Browser->Start).

prometheus
08-11-2011, 12:28 AM
thx for the tips. Although layout seems to crash constantly. Like every 2 minutes. Is there a solution to this?

Yes there is, but to tackle the problem..one need to know what Lightwave version you are using:D

Michael

Danner
08-11-2011, 02:56 AM
If you have subpatches turn their display resolution to 0. You could also hide things that you are not going to tweak from showing up in openGL.

toby
08-14-2011, 06:10 PM
I second the Turn Off the damned Hub suggestion. That should help the crashing and maybe a little speed; Particles have really slowed things down for me too, so I also second the deactivate suggie.

If it still crashes, convert and get rid of any JPGs you're using for textures, lw doesn't like them, and it gets bad when you have a lot in memory. JPG quality sucks arse anyway.

kosmodave
08-14-2011, 11:33 PM
Yes I always turn off the Hub as well. For anyone using Lightwave10 or 10.1 you don't really need the hub anyway as it has a connection developed for Core still enabled. All you need to do if you are not using the Hub is to load the same mesh in Layout and modeler and just model away as normal and everytime you select save in modeler it automatically updates in layout.

A Hub without using the Hub, the best bit of LW10 really. :p

Dave.

skywalker113
08-19-2011, 05:28 PM
I am modeling a very dense spaceship with at least 2-4 million polys. I can move around in modeler in open GL very well. execpt when I decide to select a polygon or copy and paste a poly group, I have to wait 30 seconds to a minute for the program to respond.

I put the spaceship in one layer because I dont want to hassle with multiple layers in layout. If I decide to use the ship as a mask, I need to change the settings of all its 50 some odd layers.

Plus if I decide to replace the spaceship with a proxy, if one litte thing is not set up right, it wont replace all of its parented layers. So I still need to click replace object layer on all of its layers.

Im using lightwave 9.6 and 10 but they both crash equally.

toby
08-19-2011, 06:23 PM
Per-point or poygon operations always take longer than per object, even in other apps. How about splitting it into 4 parts?

Did none of the crash fixes work, what were you doing when it crashed -

skywalker113
08-19-2011, 09:50 PM
Per-point or poygon operations always take longer than per object, even in other apps. How about splitting it into 4 parts?

Did none of the crash fixes work, what were you doing when it crashed -

The only thing I know is the crashes occur after a command. Such as move, rotate, layer switch, extend, etc. I called newtek before and the only thing they say is to delete the Lw.CFG files and restart lightwave. It doesnt prevent the crashes from occuring.

The crashes dont just occur with complex objects, they can occur with very simple objects as well(Like only a couple thousand polys).