PDA

View Full Version : Deform: Pole



Chrusion
08-03-2011, 11:00 AM
Even though I have LW 10.1, shouldn't the Object Displacement Deform plugins work the same as the LW 9 manual describes? Deform:Pole is not.

I have a highly subdivided vertical tube 10 ft tall x 5" dia. I add nulls named Pole Center and Pole Range to the scene. I add Deform:Pole to the tube. I set its options to use Pole Center and Pole Range as its "handle" controls.

I place Pole Center at the top of the tube and Pole Range a couple feet away on X (or Z), but on the same Y plane. I move both nulls on Y down to the end of the tube. I scale Pole Center from 1 to 5 and back down to 1 over the length of its path.

The tube DOES NOT bulge at all, does NOT deform an iota. Why? Yes, the plugin has a check in the On column of the tube object's displacement plugin slot.

34 words in the manual are obviously NOT sufficient to properly set this up, that or it's broken in 10 x32. Please help or confirm inoperation.

.

dwburman
08-03-2011, 12:04 PM
I just tried this out and it took a little while to figure out how to get it to work. The trick is that you need to scale up the Base null in order for the bulge to happen.

Edit: oh wait, you did that.

Edit Edit: You need to move your handle control in all 3 axis. It defines the outer corner of the effect. Think of the corner null as being the corner of an invisible box that is mirrored on all the axis, with the center null as the center of the box. If the corner is in the same plane as the center (either, X, Y, or Z), you'll have flat plane instead of a box.

Chrusion
08-03-2011, 12:20 PM
I've even scaled it up to 100 and moved Pole Range way far away. Nothing.

To be fair, I do have PFX applied (but unchecked), but that should have nothing to do with Displacement plugs as I had MorphMixer applied (now it's not) and the tube deformed with or w/o the particles "on."


Edit: Yeah, I tried moving Pole Range all over the place. Attaching the scene....

dwburman
08-03-2011, 12:35 PM
I'll take a look at your scene.

Here's one I made that works:


Edit:

I looked at your scene and the Pole Range Null is in the same plane as the Pole Center Null in the Z axis. If you move it to 3.2m you should get closer to the effect you're looking for. Also, you'll probably want to reduce the amount you are scaling the Pole Center in the Y axis.

Chrusion
08-03-2011, 12:41 PM
Nevermind... I cleared the scene and started from scratch, starting with applying Pole first... works.

Yeah... the Range null cannot be "in line" with any of the axis of the Center null... has to be offset in ALL three axis'.
Adding that note in the LW 9 printed manual, cuz "corner" just isn't a strong enough word to make that "visible"
in my imagination, especially since the screen cap appears to show the range null as being coplanar on Y with center.

Thanks for your help!
.