View Full Version : Network Render setup app free

07-25-2011, 11:09 AM
Is there a free network render setup application I can use. This screamer net is really confusing to me.

07-25-2011, 12:30 PM
What OS are you on? If you are on a mac you can try this thread: http://www.newtek.com/forums/showthread.php?t=77993

I'm on a mac so I use this (DLI_SNUB-Launcher). Even if you are not on a mac I recommend looking around their site, as there is a lot of useful info there. It is not free but reasonable. I will look some more, for info on a pc. I've always just used screamer net, but it took a long time to set up the first time I did it.

07-25-2011, 12:32 PM
Also, try this thread: http://www.newtek.com/forums/showthread.php?t=24065

There are video tutorials on setting up screamernet.

07-25-2011, 12:37 PM
This is the best thread: http://www.newtek.com/forums/showthread.php?t=26572

Matt Gorner's tutorial is the best and the one that got me up and running.

07-25-2011, 01:50 PM
Win7, is os. I would love just to use screamernet (still confusing). The videos that Matt made are gone. If those are still helpful for lightwave 10; I would like to download that video.

07-25-2011, 01:55 PM
This is from FAQ section of mine new website:

Q:How to setup LightWave renderfarm?
A:The first step is to create NAS- Network Area Storage. The simplest way is to share in network some folder, on machine which has fast hard disk and is running all the time, with read and write access for everybody in LAN.

You should make there Content, Commands, and Config directories.

Copy your local LightWave configuration files to Config directory.

Run text editor, such as Notepad, and make script looking like:

cd "[path to LightWave executables]"
lwsn -2 -c"\\SERVER\LWSN\Config" -d"\\SERVER\LWSN\Content" "\\SERVER\LWSN\Commands\job1" "\\SERVER\LWSN\Commands\ack1"

Where SERVER is the name of your all the time running machine.
And LWSN is name under which you shared folder in network.

Make as many such scripts as you have machines in LAN, replacing job1 and ack1 by unique number at the end.

Path to executables- to simplify life you can install LightWave on just one machine, and allow other to see that folder in network with read-only access. Setting read-write access for this folder is not recommended because some virus might scan LAN and searching for executables to infect.

Run scripts on the all machines.

Run LightWave, open Render > Network Render, and pick up \\SERVER\LWSN\Commands\ and Command Directory and let it initialize.

07-25-2011, 01:56 PM
Win7, is os. I would love just to use screamernet (still confusing). The videos that Matt made are gone. If those are still helpful for lightwave 10; I would like to download that video.

Have you tried youtube? There a few videos on their regarding Lightwave screamer net. This one looked like it was being set up on a win7 machine: http://youtu.be/s-QDpWMZPMg They are setting up LW8 (if I remember right) but it would be the same for LW10. Not much has changed regarding screamer net.

07-25-2011, 02:11 PM

They sell a network rendering controller, but also give away a free utility to help you set up your network even if you don't buy the full thing.

07-25-2011, 04:36 PM
this is my script for setting up a node
@echo OFF
echo "LightWave ScreamerNet Node 1"
cd "\\LEGOLAS\Lightwave\bin"
LWSN.exe -2 -d"\\LEGOLAS\Lightwave\bin" -c"\\LEGOLAS\Lightwave\screamerconfig" "\\LEGOLAS\Lightwave\screamercommand\job1" "\\LEGOLAS\Lightwave\screamercommand\ack1"

When i try to run it it does not stay up. Any ideas?

07-25-2011, 05:04 PM
Ok so I have made some changes but it still does not work
Here is the script again

echo "LightWave ScreamerNet Node 1"
cd \\LEGOLAS\Lightwave\bin\

LWSN.exe -2 -c\\LEGOLAS\Lightwave\screamerconfig -d\\LEGOLAS\Lightwave \\LEGOLAS\Lightwave\screamercommand\job1 \\LEGOLAS\Lightwave\screamercommand\ack1

07-25-2011, 05:15 PM
The only thing I can see is that I don't think you nee the .exe on LWSN. Try it without that. Again, it has been a long time since I set this up on a PC and I haven't touched a Win7 machine yet.

07-25-2011, 05:19 PM
Just tried that. Still nothing

07-25-2011, 06:10 PM
Use Start > Execute... and run cmd.exe and paste your script there, without log off, and you should see reason why is it quitting immediately.

Maybe \\LEGOLAS\ has just read-only access??

Read mine FAQ.
LightWave bin should not be in the same location as the rest of Content/Configs..

07-25-2011, 06:14 PM
Make sure you are putting the .bat file you are creating in the same folder as where your lwsn.exe is.

07-25-2011, 06:15 PM
Make sure you are putting the .bat file you are creating in the same folder as where your lwsn.exe is.

That's why there is "cd" command at the beginning..
To not have to do it.

07-25-2011, 06:21 PM
I got it working as a shortcut not a .bat. So all the jazz is happening, but i don't see the rendered files. I set up it to export as a jpeg is that going to be a problem?

07-25-2011, 06:25 PM
you must use location visible in network..
f.e. inside of Content directory.

07-25-2011, 06:26 PM
I got it working as a shortcut but not as a .bat file type. So now the problem is that i don't see any files going into the place I told them in the scene file.

07-25-2011, 06:27 PM
I told them make them to be .jpeg is that a problem?

07-25-2011, 06:31 PM
Maybe you didn't set up LWSN correctly and plug-ins can't be found?
Plug-ins must be in such location they're available for LWSN in network.
f.e. cfg file has added plug-ins from folder C:\Program Files\NewTek\LightWave 3D 9\Plugins
of course when run from 2nd machine such folder doesn't exist and they can't be lunched.

07-25-2011, 06:32 PM
Arg it is like they are not working right. They are not working at all on the frame.

07-25-2011, 06:32 PM
Well they are, just it takes no time at all to render the frame

07-25-2011, 06:38 PM
Ok i just caught the beginning of the render node it said "unable to access the scene file.
Now in the script for the node is -d the location for all the render content like scene files and models?

07-25-2011, 06:45 PM
Ok it is. lol :) It is all working!!!! Thanks for all your guys help! Thanks Sensei for the network rending with out moving a ton of files