PDA

View Full Version : Modeling in widescreen



lreyes
07-21-2011, 02:00 AM
Hope I am making a sensible question, but I will ask anyway. Is there a way that I can model objects on a widescreen interface in modeler, or is there some way that I can make my layers in modeler widescreen, so when I go to layout the aspect ratio is correct for widescreen. Right now I am making my scenes in widescreen and making my size 864X486 and adjust the aspect ratio to cover all my monitor screen to make it widescreen with no empty space top or sides. I use this so when I go to Adobe Premiere it will not squeeze my editing. I find this fills up my Flat widescreen TV okay. I just thought there would be a simple way of doing t his?

Danner
07-21-2011, 03:31 AM
Not quite following you. What does modeler have to do with the correct aspect ratio of your editable video? Are you recording modeling sessions? if you want to frame your objects so you only model what you will be seeing, you could create an actual polygonal frame of the right proportions I guess.

lreyes
07-21-2011, 06:25 AM
I think you answered my question partly, in other words I would have to make my models a little fatter or thicker to show correctly in layout. I think my problem now that I think back is that when I created some objects or models and render them in layout months ago, I did them at different size and when I brought them back to layout now, and used a different resolution and screen size, they looked thinner...but yes, you answered me...thanks

kopperdrake
07-21-2011, 07:18 AM
Now I'm even more confused than before...it sounds like your monitor settings aren't correct if they're coming out distorted. If you model a cube 1m x 1m x 1m, it should look square in either Modeler or Layout's interface. If not, then you need to alter the monitor's resolution. Is that it?

BigHache
07-21-2011, 07:27 AM
Either that or maybe the render settings are not correct? The part that confuses me is setting the camera to widescreen resolution, and adjusting aspect ratio. That latter part sounds like it may be the culprit.

lreyes, is the pixel aspect ratio in your Camera settings 1.0?

Dreamcube017
07-21-2011, 07:40 AM
Hm, if you make a sphere in modeler, is it completly round (not egg shaped) When you export that sphere to layout in perspective view (not in the camera) is it still round?

1. If it's egg shaped in modeler, layout, and in camera, your monitor is at the incorrect resolution.

2. If it is noirmal in layout perspective view but egg shaped in the camera, something is not right in your camera settings.

3. If it's egg shaped in layout, but not in modeler... then I'm not quite sure what's going on there.

Aspect ratio only has to do with how wide of a viewing angle you get. So weather it's 4:3, 16:9 or even 20:2, the sphere should still be completly round, and not streched or thinner.

Danner
07-21-2011, 08:45 AM
I understand now I think. You should be working on a monitor with a 1:1 aspect ratio. If you are using a plasma or LCD screen television as a monitor and it doesn't offer square pixels (quite common actually) you are in for a world of pain.

If you are using a 1:1 monitor and want to render to a different aspect ratio for strange reason (I never have to anymore I just render HD rez with square pixels) then the aspect ratio should be set at render time, never at modeling time.

I'll give you an example of why this will not work. If you model a circle and correct the pixel aspect in modeler, it becomes an oval in one direction, if you rotate the oval 90 the pixel aspect would be 200% wrong.

sandman300
07-21-2011, 09:03 AM
It sounds like your rendering in D1. The video output looks odd because the video software is not compensating. The pixels in the video are not square but the software is making them square. You might be able (and I haven't used Premiere in a long time) to correct this in the video properties of the clip. Now D1 is standard definition, so if your goal is a HD TV than you don't want that. If you render at a HD size all of your models will look fine.

I've always thought strange that wide screen and full screen were actually the same size - 16:9 and 4:3 are both 720 x 480. The only difference is the shape of the pixels or the pixel aspect. It's basically a hack that was created to deal with a technological shortcoming of SD TVs.

Edit: I Just reread your post.
[Right now I am making my scenes in widescreen and making my size 864X486 and adjust the aspect ratio to cover all my monitor screen to make it widescreen]

You want to stay with the presets, Monitor and TVs shapes are industry Standards, No reason to custom size for the monitor. Also it is usually best to leave the pixel aspect alone.

K-Dawg
07-21-2011, 09:11 AM
To me it sounds like he's modeling in Modeler and the perspective viewport is distorted and he's compensating that somehow with some monitor or so settings. Then when the distortion is somehow compensated for Modeler, in Layout the thing is distorted again. Maybe cause the Model is modeled to look "correct" in Modeler, but then in Layout it's messed up.

Use the Display settings in Modeler and control the Perspective Distortion there and not anywhere else i.E. Hardware.

Greetz

lreyes
07-21-2011, 09:55 AM
Thanks for all those tips...I think I am doing okay as when I did a render of the moon and stars, the moon shows round and not oval. Here is what I am rendering in: D1 widescreen NTSC. with resolution of 864X486, Pixel aspect 1.2 and using perspective camera. Before, I was not messing with the aspect ratio when using D1 widescreen and when I edit my scenes in Adobe Premiere and make a movie the results look different, i.e. the moon is not completely round, but when I use the above setting and bring the scene in the editing software and make a movie, the moon is round like it should be.

lreyes
07-21-2011, 10:07 AM
forgot to mention that before I was using a lower frame size, when I switched to 864x486 did I get the round moon after making a movie in adobe premiere, before that I was getting an oval moon, so it was the changing the frame size to 864x486 did the problem seemed to correct itself.

dwburman
07-21-2011, 10:55 AM
EDIT: This info assumes you are outputting to a video display. If your final destination is computer screens, you can disregard most of it, since computer screens have a pixel aspect ratio of 1:1.

864x486 is kind of a hack. You're rendering extra pixels so you can have a wide screen image on a square (1:1) pixels device. Standard Definition video is a non-square pixel format, so TVs and DVD players are designed with that in mind and will stretch the image accordingly at playback time.

Try rendering with the NTSC D1 widescreen preset in LW (which is 720x486)

It might render a bit quicker since you're not rendering 120 extra columns of pixels.

When you get your clip into Premiere it will look squeezed. You'll have to tell Premiere that the clip is widescreen (Final Cut Pro has an "Anamorphic" check box in clip properties to do this) and it should stretch it out to be full screen.

It's not a modeling issue, it's a pixel aspect ratio, therefore a rendering issue.

Read the adobe help file on aspect ratios. The pages are fairly short:
http://livedocs.adobe.com/en_US/PremierePro/3.0/help.html?content=WSbaf9cd7d26a2eabf53ab0410410812 90f-7ffd.html

lreyes
07-21-2011, 11:07 AM
I will try what you said using D1 720x486. You are right about rendering with 864x486, it takes a long time. I used widescreen on adobe premiere before, but when I make it into a movie and play it on my widescreen tv, it does not fill the whole screen and the moon is not completely round unless I am not using premiere correctly as I suspect the problem is with premiere.

BigHache
07-21-2011, 11:18 AM
Aspect ratio correction is only for TVs. As dwburman mentioned, the D1 NTSC Widescreen preset will be what you want, for both Lightwave and Premiere.

Rendering at a resolution of 864x486 AND adjusting the pixel aspect ratio to be wider than 1:1 will definitely not work because you're compensating twice for the issue of non-square pixels on TV.

D1 NTSC Widescreen renders to 720x486, but compensates for the pixels to be stretched to 1.2. This is how SD DVDs get the letterbox format to display proper on TV. If you wanted a still to display on your monitor, you'd probably want to render at a native "widescreen" resolution like 720p with a pixel aspect ratio of 1:1.

dwburman
07-21-2011, 11:18 AM
It could also be the settings on your TV or a combination of TV settings and your output device.

This aspect ratio stuff can get confusing and broadcasters still seem to have problems getting it right.

How are you getting your picture to the TV? What cables/inputs on the TV are you using?

lreyes
07-21-2011, 12:04 PM
Wow, I want to thank you guys for helping me out...I found out where the problem was, it was in adobe premiere, as I did not set the right ratio there. In Adobe Premiere that is a "Interpet footage" that gives the ratio that I want to use, once I click on 720X480 1.23 ratio or there abouts, I get a wideimage on my work window in adobe premiere and it renders as such...Also using 720 480 give me a quicker rendering time...thanks.

lreyes
07-21-2011, 12:14 PM
wow, I found my problem thanks to all of you..It was in Adobe Premiere, I found where the adjust for proper aspect using 720X480 in the "Interpret Footage" window, now I can see my imput from my modeling get from squeezed to widescreen...now using 720X480 renders faster also."Thanks"

lreyes
07-21-2011, 12:34 PM
I posted two thanks to you all, but I do not think it posted. I just want to say that I found out where I was having trouble, it was in Premiere 9.6 as I found out where to change the ratio in the "Interpret Window", so now I can render at 720X480 and less rendering time. Now my imput sequence is widescreen in the editing window of adobe premiere. Thanks.

dwburman
07-21-2011, 02:36 PM
Glad it worked out for you! (x3)