PDA

View Full Version : Rotate vs. move in viewports at high zoom - frame rate?



madno
07-15-2011, 01:49 AM
Navigating in the viewports (rotating or moving "camera" in perspective view in modeler or layout) is very fluid as long as I am not zooming in to much.
When zooming in, moving the camera is still ok but rotating gets very, how to say, jumpy. It feels like playing a 3d game with only 2 frames per second. Moving the mouse as slow as possible first results in a lag and then a big jump of the geometry in the desired rotation direction.

I checked with a 4500 poly opject and a simple box (just geometry, no textures, dynamics, morphs etc.). There is no difference. So I don't think its a to high load for my workstation.
Dual CPU (Xeon E5520 quadcore), 16 GB Ram, 2 x Crucial SSD, Nvidia GTX 580 (3 GB).

I tested changing:

Display options -> Interface -> fine detail cursor (on/off)
Display options -> Interface -> grid snap (on/off)
all the different shading methods in perspective view
switched off all advanced options in Display options -> GL (Reflections, Transparency etc.)
AA in Nvida driver panel (on/off)


Does anybody have and idea what could cause this?

EDIT:
Forgot: LW 10.x, Win 7 64 bit.

cagey5
07-15-2011, 02:23 AM
It may be your grid size. If it's too large, as you zoom in the snapping will appear greater. Reduce the grid size and see if that improves it.

madno
07-15-2011, 03:18 AM
Thanks for the tip, but in modeler I don't find an option to resize the grid square size (its only available in Layout). I already switched off snapping, so it should not have any influence, right?

Cohen
07-15-2011, 03:33 AM
hmm, I'm not entirely sure what the problem that you are describing is. But it sounds to me like you have difficulty navigating a large mesh in modeler, especially when rotating about small areas?

If this is the case, the best thing to do is reset your camera around your selection that you want to work at. Simply have some elements selected where you want to work (some points or polygons for example), then hit 'Shift + A' to center the camera on that selection (it will center all viewports). From there, you should be able to do your camera tumbling/rotation much easier that way.

Oedo 808
07-15-2011, 05:38 AM
While I have found some issue in LW10, I notice you asked about utilizing AA, certain settings can have a hefty impact on viewport performance as 3DGFXStudios mentioned, so I avoid using it. I suppose it's fortunate that I prefer not to have it enabled anyway for the majority of meshes.

As you have stated using AA on/off, did you restart Modeler when you were testing this?

RebelHill
07-15-2011, 08:25 AM
Its because when you rotate each mouse "step" rotates the view by a given number of degrees (like 0.1 or somesuch)... when zoomed out this tiny change in angle doesnt appear to be much, when zoomed in it appears exaggerated, thats all.

madno
07-16-2011, 01:39 AM
Hi, thanks for all your tips. I had the impression, that it is the mouse, like RebelHill said, as well (made a test with 3dcoat and its the same there).

Last question, is it possible to adjust the rotate angle steps in some way (buying another mouse, mouse driver, LW config etc.)?

By the way attached is a video showing the effect (I nearly did not move the mouse while recording the jumpy rotation).

Cohen
07-16-2011, 03:24 AM
hi, as I said earlier, you need to select some points (like the corner of the cube in your video) and press 'Shift + A'. Reason being is that the camera in modeler is not actually translating in space. It is impossible to traverse from one quadrant to another in lightwave's modeler, because that widget you were using only performs a zooming operation on the GL viewport.

you should also not get into the habit of using the viewport widgets. (The gui controls). Do the following instead.

Hover your mouse over any viewport and:

alt + left click, to rotate camera
alt + shift + left click, to pan camera
alt + ctrl + left click, to zoom camera

hope this helps.

madno
07-16-2011, 04:01 AM
Hi Cohen,
will do that (although the widgets are magically pulling at my hand all the time).

amath
07-17-2011, 03:42 PM
I wish we could do this like in layout.
Position camera, rotate or zoom and pan.
Seem to have much more control this way.
Especially on large house models I need to edit.

Danner
07-18-2011, 07:53 AM
This happens because your center of rotation is far from what you are seeing. That also spawns another common issue, polygons start to dissapear as you zoom into them. There are two work arounds for this. One has been mentioned, which is to center the "focus" of the perspective view close to what you are editing by selecting a point there and auto centering. The other method is a bit harder to explain without you seeing it. But it goes something like this: find what you want to focus on, then turn around to the opposite side and zoom back. Sort of backing into it. It sounds odd but it works.

madno
07-19-2011, 12:09 AM
Hi Danner,
noticed the dissapearing polys myself and use the same workaround you mentioned. Thought it is related to my graphics card. After getting all the answers here I now understand its not something like a bug but a general technical limitation. Anyway "Shift + a" does a good job most of the time.

One more question about rotating with short cut instead of widgets.

I learned one can rotate with "alt" + mouse in the viewport. Works fine but rotates to all directions according to where I have the mouse pointer. Is there another key that limits the rotation to only left <-> right or up <-> down?

Danner
07-19-2011, 03:18 AM
alt = rotate
alt ctrl= zoom
alt shift = pan
Forget the widgets are there. As for the free rotation, I don't think there is a way to limit it, the good news is you'll get used to it and even miss it if you don't have it (other apps).