PDA

View Full Version : More Aliasing Issues



digitalimagery
07-13-2011, 02:02 PM
I was having trouble with a proper render setting to get rid of aliasing and "It seemed" the problem was solved with the help of this forum. Turns out the renders in LW looked better using perspective camera with a higher Antialias setting and the Mitchell Filter but when I key the render from the alpha it still has issues on the edges.

After Effects overshoots the smooth edged alpha in their RGB channel for clean keys as does Electric Image which blows my mind how nicely the edges key (including transparent glass which keys over a background as nicely as it renders over one composited in the app).

So what's the secret to smoothing out the matte in LW? Is it a setting or is it not capable? I love what my high res test renders look like over black in the app but they just don't key worth a hill of beans when comping in AE.

Can someone help?
Thanks
DigitalImagery

souzou
07-13-2011, 02:33 PM
Not a LW tip but a couple of quick workarounds in AE.

Check your Interpret Footage settings (Ctrl-Alt-G) and try setting the alpha to premultiplied - select the colour background you rendered on (in this case black). This can clean up the edges.

If you still have problems and you're desperate, Effect > Matte > Simple Choker to choke the edges in.

digitalimagery
07-13-2011, 03:15 PM
Yeah I'm one of the original AE guys so I'm well aware of just about every trick in AE (Screen mode to key off the black, choking mattes blah blah blah). I'd really like to have 3D output the way it should be so there isn't a need for tricks. You can even see the aliasing in the alpha channel which floors me because other programs make flawlessly smooth mattes when you crank up the antialiasing.

I'm sort of new to Lightwave and just wonder if I'm missing something in the app that solves this. I'm really hoping I'm not investing my time learning this program if something as simple as getting clean keys isn't achievable.

I've had multiple issues with the way it spits out glass. I don't want to composite in the program to have glass key properly. Over the years I've tried to get an answer to why the renderer can't over saturate the rgb channel with the necessary fill to key what I see in my tests. Other apps (E.I.) make what looks like a mess of over saturated color on the rgb output but the alpha looks exactly like it should in greyscale. Once keyed you get exactly what you saw in the render test. Apparently not possible in LW.

Thanks for the response.
DigitalImagery

raw-m
07-14-2011, 12:49 AM
Just a thought but rendering from LW, try setting the Alpha Format to "Unpremultiply Alpha". Basically it means unmatted in AE world. It works much better for me.