PDA

View Full Version : How do you delete polys from UV map?



sami
06-07-2011, 10:00 PM
I've duplicated a UV map and I want to delete specific polys from one of them and delete the inverse from the other so that I can separate the one existing UV map into 2 maps and then scale them differently.

How can I delete polys from individual UV maps in LW?

thanks :)

nickdigital
06-07-2011, 10:27 PM
I believe if you select the polys you don't want and hit Clear Map it should remove them from the UV. What I normally do is select the polys that I want and copy them to a new map and then edit them there. From there you can do the same operation by merging all your separate UVs into one. A few more steps but I know it works. There's so many UV tools in Modeler I usually just stick with what works instead of experimenting with all the different variations of the same tool.

zardoz
06-08-2011, 09:32 AM
first I do unweld all, choose the ones you want and copy map, then clear map.

lightmann
06-08-2011, 12:53 PM
so,method 1 (nickdigital) if you want to preserve point indexes,very important for fluid exchange with other applications.
Method 2(zardoz) if you keep the things inside lw and more quickly.
Select and clear as you see dont work as expected, unweld is always necessary but not always the best choice.

sami
06-08-2011, 03:20 PM
hmmm Select and clear without unweld seemed to work fine for me. Not sure why? Thanks for the tips though. That was exactly what I needed. Now if only 3DCoat will import this new UV map then all will be good... :)

zardoz
06-08-2011, 03:57 PM
if you select a group of polys to clear from the current map and you don't unweld them from the rest of the object, when you clear them from the map, the polygons around them will also be cleared.

sami
06-08-2011, 04:42 PM
that would explain why the 1st time through the neck was missing from the UV in 3D coat when I imported it. I unwelded and did it again and it worked right. Didnt notice those small polys gone. Thanks for the tip.

These tiny workflow things escape from my brain the less I use them daily... ;)

probiner
06-08-2011, 06:37 PM
I normally don't apply Clear Map to polys, always to points.

The easiest way i find to unweld witouth unwelding the points actually, is to Move them in the UV Viewport with "Free Move" on. This way the polys will be ripped from the rest of the polys, to an isolated area, lasso select them and 'Clear Map'.

Inversely, I also do something similar when UVs get dirty. Move the good UV's Polys out of the 0-1,0-1 space, leaving all those dirty points behind, that are selected and cleared. Then, move the good polys back to 0-1,0-1

Cheers

jeric_synergy
06-12-2011, 03:54 PM
::scratches head:: I think you may be making extra work for yourself there, Probiner. Using Unweld, then switching to Polygon mode has the same effect as your steps, but with perhaps fewer mouse motions.

But then, my UV ignorance is pretty comprehensive, so ...... >;^)

evolross
11-11-2011, 02:43 PM
I'm having a UV problem that's plagued me for a long time and in the past I usually figure out a way to get around it, but I don't think I can on this one.

I have a subdivision basketball object with large orange sections that get UV mapped for graphics and texture. There's also black basketball seams running between those sections that are a part of the overall model and the whole thing is connected/seamless.

The problem is when I unweld and UV map the orange sections using PLG tools, everything looks great. But then I have to merge points on the whole model to make the geometry of the seams look right again. On my UV maps the seams pop on and are stretched crazy between my nicely laid out orange sections. This wouldn't be a problem but it's STRETCHING the edges of my orange sections, distorting the texture.

Once I've merged points, if I try to clear the crazy seams off the UV map, it works, but it also clears off the polygons surrounding the seams, which are the edges of my orange sections which I need on the map.

I have to keep the model merged or the geometry doesn't look right. I've tried everything and the only options are to have the small edges of my orange sections stretched or not have them mapped at all.

What's the solution for this?

probiner
11-11-2011, 03:43 PM
Can you provide model or a section of it where on can check the problem?

zardoz
11-11-2011, 04:46 PM
try something like this:
1st: unweld everything
2nd: cut everything (polygons) and do a clear map (some times some point are left behind and cause these strange problems)
3rd: paste everything back again and cut the black seams and paste them in a new layer.
4th: use plg to uv the orange parts
5ht: use pkg to uv the black seams (even if you don't need them to have uvs)
6th: arrange the black seams uvs, cut them and paste them back to the other layer with the orange parts.
7th: merge the points.

do you still have the problem?

evolross
11-12-2011, 03:15 PM
Thanks, that workflow did the trick. :thumbsup: So what is the trick... UVing them on separate layers first? Or just that I separately UV'd the seams? I wasn't doing that before.

I taught myself 3D, never took any classes. I always chuckle at the little pockets of knowledge that I sometimes lack because of this.

zardoz
11-13-2011, 04:06 AM
yes, if you uv the different parts in different layers will help prevent that to happen. Because if you select some parts of the mesh and uv those you are uving points that also
belong to the parts not being uved (someone should make a verb out of this).
So when you merge the mesh it connects the points and it makes a mess.