PDA

View Full Version : Ok I'm finally deciding to learn rigging....



Alliante
06-03-2011, 08:51 AM
And I'm having a heck of a time trying to right this little test robot mech thingie I threw together.

All my joints are on separate layers and parented properly, but the IK goals are just not working as I'd expect. I'm most certainly not asking someone to do it for me, I'm just wanting to know what I'm doing wrong.

How I'd expect it to work:
Rig all legs in the following format:

Body(same as next line)-> Right Thigh->Right Calf->Right Foot
Body(same as above line)->Left Thigh->Left Calf->Left Foot

Set IK goals (point to goal, keep goal in reach) of thighs to calves, and calves to foot (IK always on).

I'd EXPECT that when IK is turned on all I have to do is move the foot and the legs should follow.

Attached is my simple scene (please don't judge me by the test object ;) )

RebelHill
06-03-2011, 09:07 AM
yeah... you've misunderstood the basics of IK setup.

To do what you're wanting to do here, You'll need the following.

First off, make nulls to act as the IK goals (one for each leg). Next set the pitch controller (in controllers and limits) for the thigh and calf from Keyframes to IK, and lose the "look at goal" and goal item entries for those items. lastly, set the foot item to have the appropriate goal null and behavior "go to goal", MGo and full time IK on.

That'll get you started.

4dartist
06-03-2011, 09:08 AM
Rebel said it all. That was the first time I rigged without using bones lol. It was freaking me out to see the ik chain but no bones haha. Never really thought to do that. However I almost never mess with an objects pivot point. It just makes it easier to mess with hierarchy for me when things aren't using a fake origin. So I'd lean towards nulls or bones. Either way it works.

I rigged up the leg so you could see it working.
-Set rotation in Pitch on thigh and knee to IK (motion properties)
-Set foot to have the IKnull as a goal, and match orientation if you want to just control the null. Select the body and turn on Unaffected by IK of Descendants. Double check that "Enable IK" is on in the Setup tab.

Alliante
06-03-2011, 09:10 AM
RebelHill: Thanks for the nudge, I'll look into working on it as soon as I can :)

4dartist: There are no bones, I think you see the IK goals or something.

Alliante
06-03-2011, 09:55 AM
Ok. THANK YOU BOTH for helping me visualize what was needed to be done... and a special thank you to 4dartist for helping me work with a working example!

This is why I haven't moved away from Lightwave: the awesome community & vendor support :)