PDA

View Full Version : Particle / wind issue



Ty Catt
05-18-2011, 01:13 PM
Hey y'all,

I have a setup involving a tube, a particle emitter and a wind generator.

The wind pushes the particles nicely through the tube using the Animation Path function and using several handles to control the particle direction.

I need some of the particles to deviate down an offshoot of the pipe halfway through the scene, so I added another wind generator and... the particles won't deviate from the path (due to the handles I assume).

Is this a limitation with the path handles- they lock the particles firmly in that path?

Any workarounds to use both handles and add'l wind gennys?...

Thanks!

prometheus
05-19-2011, 01:07 PM
depends on your wind settings power etc..try increase the wind power of the secondary winds to 5000-1000 to see if something happens, but it also depends on particle weight/resistance.

Im not sure thou if there was some problem with that within LW 9.6.
But in lightwave 10 secondary and even a third wind affects the animation path wich the particles flows by.

Michael

jeric_synergy
05-19-2011, 01:11 PM
By "some" do you mean "a couple" or "a couple hundred"?

For the second case, I'd just use a second emitter for that path. Clone the original emitter, and half the birth rate of the original and the clone. Set the clone's lifetimes to end about where the second path begins. So, half the original's amount will die out just in time to be replaced by the new (non-cloned) emitter's particles.

(I've often found though, that something like this, that "should" work, often does not, sadly. But it might.)

daforum
05-19-2011, 04:06 PM
Have a look at this tutorial for tips:
ftp://ftp.newtek.com/multimedia/movies/w3dw/dl_link.html?waterpipe.mov

Hope it helps :)

Ty Catt
05-20-2011, 08:01 AM
Thanks for all your replies!

The particles are actually blood cells and they are occasionally leak out of the vein (pipe) through a small tear in the vein wall.

So I am not sure if creating a new emitter would work unless I hang the camera back some and have some floating cells obscure it's sight line.

I will give all your suggestions a crack.

Thanks!

daforum
05-20-2011, 03:37 PM
Let us know how you get on; and maybe post some screenshots
(or even a link to the final movie) :)

OnlineRender
05-20-2011, 03:44 PM
build it in another scene then bring it back in

jeric_synergy
05-20-2011, 05:47 PM
If it's literally just a few, you can just edit the motion paths directly.

Ty Catt
05-23-2011, 11:09 AM
Thanks again eveyone,

Online- do you mean load items from scene? I am sorry, not quite sure what you are getting at (won't be my first time!)

Jeric- I also am not sure what you mean... aren't the handles directional only, do they have add'l editing capabilites?

Thanks, guys.

Tyler

sunspot
05-23-2011, 02:22 PM
Hi everyone - please forgive my novice status for another particle question.
I am animating electrons "seeping" out of a pipe and then being controlled by cathodic protection.
I have the particles set up (YAY!!) but now I need to reverse them at a specific point in the animation and have them go in exactly the opposite direction. Other things have to happen in the scene as well, so I am hoping there is a way to do that without rendering and reversing the frames in After Effects.
I am using Lightwave 9

Can anyone point me in the right direction?
Thanks a bunch,
Barbara

jeric_synergy
05-23-2011, 02:39 PM
Particle animation has playback control..... crap, it's not enveloped!!! WTH?

There's gotta be a way to load a PFX file and control the playback...it maybe bthat you'll have to save a MDD file and playback that. I bet DPont has a node that will address and allow you to envelope the playback of an MDD file.

daforum
05-23-2011, 03:19 PM
Once saved a PFX motion, set the playback mode to 'Key'
Select the emitter and make a keyframe, the PFX motion will start on that keyframe.

jeric_synergy
05-23-2011, 05:33 PM
Still doesn't let you go backwards.

I'm a little flabbergasted that there's no "playback envelope", like time-shifting in AE. I would've bet that existed.

Ty Catt
05-25-2011, 01:08 PM
Boy, do I feel dumb.

Why didn't I do this sooner: instead of using another wind emitter (which you guys were right worked once I increased the power by a buck or two) I just plugged in a collision object and set it to attract.

Although with collision ->attract the particles kind of bounce around inside the attractor rather than pass through it... have to work on that.

It will take some tweaking, but I think it will work. Once I finish the project, I'll attach a link for viewing.

Thanks again, everyone!