PDA

View Full Version : Nasty Animation Render Results?



SLAYER
10-04-2003, 09:36 PM
Hi,

I am attempting to make some animation AVI's now that I have learned modeling.

I did a simple 60 frame animation of a box with a door opening to give it a shot and the render turned out all saturated in color. It is all yellowish and nasty looking. What is this from?

A single frame renders awesome and exactly how I would like. Why doesn't the animation file turn out the same?

Also, I do not understand all of the compression settings for saving as AVI and as a Quicktime. What are all of these and what is a good basic all around one to use?

Thanks

Mylenium
10-05-2003, 06:12 AM
Never render animations! Animations are evil! You will learn that latest once you have a crash and hours of rendering are lost. Always use image sequences. But on to your problem.

Most likely you used a compression in your AVI. Apart from just compressing the image, there is also many other things going on such as color space conversion. This will always cause a minor shift in colors (normally not noticeable) but sometimes it gets off tracks.

I suggest to do the following: Save your animation as RGB images and then put them together with a tool such as VirtualDub (or compositing and editing programs such as After Effects and Premiere). Then play around with compression settings there as well as all other tweaking options. There can be no ideal compression since this is largely dependent from the target media, but DiVX will still give you the best quality for AVI and be good enough for most things.

Mylenium

hrgiger
10-05-2003, 07:17 AM
Originally posted by Mylenium
Never render animations! Animations are evil! You will learn that latest once you have a crash and hours of rendering are lost. Always use image sequences. But on to your problem.



Well, I wouldn't say never....

I always render individual frames and an animation. No reason you can't do both.
I agree that Divx is an excellent codec to use. Very good quality and small file sizes.

Tom Wood
10-05-2003, 07:36 AM
When I've rendered out indivudual frames in .tga, it fills the directory with, well, individual frames, that have to be dragged into the TED timeline, filling IT with a bunch of individual frames. Is there a way to save the frames in a folder that can be dragged into the timeline?

TW

ruud
10-06-2003, 03:54 AM
this is called an: Image Sequence

Try to get your hands on Adobe Premiere. Insert File, click the first image of the sequence, and don't forget to mark the "Numbered Still's" Box.

There's your animation. Render from here to any output you like

Ruuterdetuutert

Cageman
10-06-2003, 04:41 PM
I can tell you another story...

At school I had turned an imagesequence into an uncompressed MOV-file which we later imported into Avid. Guess what... it looked yellow and awfull. We played the movie with Quicktime and it looked great. So... we imported the movfile again, and the same result: yellow and ugly...

We never discovered why this happened... so, after that we ALWAYS import imagesequences into Avid.. =)

WizCraker
10-06-2003, 10:31 PM
Or take your image Sequence [image0001 through whatever]
1. open new scene in layout set camera to what resoultion image sequence is in. [ie 960 x 512]
2. open image editor load image sequence. Under the Source tab under image type click from Still to Image Sequence [this tells Layout that the file image0001 has more files associated with it] close image editor
3. goto Scene tab, compositing [or ^F7 Background set the (none) list to image0001 (sequence)
4. goto Render Options, Output File tab, Check Save Animation Type in file name, under Type pick what it will be avi or quicktime or the other formats in there. Then Click options to pick which codec to use. avi - Cinepak, Microsoft, Mpeg 4, Intel, DivX, etc... quicktime - Sorenson 3, Animation, Mpeg 4, etc... Close window
5. press F10