PDA

View Full Version : Shadow Catch Only Surface?



Dracorat
04-30-2011, 04:24 PM
I'm trying to use LightWave to get started with making D&D maps.

Attached you'll see my first effort. The only thing that gets me with it is the outside green "grass" area. I don't really want it to show up at all except for what's necessary for the shadow to fall on it.

In the surface properties, I chose "Shadow Density" as the alpha channel, but since the light that falls on it isn't 100% brightness it shows up some still. How do I completely eliminate the part that the light falls on without upping the light brightness? Or do I have to do that.

Is there another way to "catch shadows" on a surface other than where I did it?

Thanks =)

http://gallery.rptools.net/d/68997-1/Church+Top.png

nickdigital
04-30-2011, 07:45 PM
Can you rephrase what you want? I'm having trouble following what you want. You want the "grass" to not show up but catch the shadows? Setting the grass surface to shadow density will make the alpha channel of that area only show the shadow.

If you don't want the grass to show up in our picture you could put the grass on a different layer and set it to "Unseen By Camera". That will have it now show up in your render but the alpha channel should still catch the shadows.

Dracorat
04-30-2011, 08:14 PM
You want the "grass" to not show up but catch the shadows?

ONLY the shadow grass would show and only partially according to the shadow opacity.


Setting the grass surface to shadow density will make the alpha channel of that area only show the shadow.

That's what I did for the first image. Maybe I can use nodes to "clamp" the brighter areas to 0% alpha?


If you don't want the grass to show up in our picture you could put the grass on a different layer and set it to "Unseen By Camera". That will have it now show up in your render but the alpha channel should still catch the shadows.

I'll try this!

ZE_COLMEIA
04-30-2011, 08:52 PM
I would use an image editor for that, just use shadow density in the grass and another render with just the grass, so you can compose in a image as you want.

Dracorat
04-30-2011, 09:56 PM
I may. But since I'm creating a scene I'm going to just set it up once and then use it for everything. So if it's possible to get it right in the output, then I'd prefer to do that because then I won't have to post-process each render. =)

Dracorat
04-30-2011, 11:25 PM
If you don't want the grass to show up in our picture you could put the grass on a different layer and set it to "Unseen By Camera". That will have it now show up in your render but the alpha channel should still catch the shadows.

No joy. The Alpha doesn't catch the shadows even with image processing effect Flare2Alpha

XswampyX
05-01-2011, 01:48 AM
What about the shadow shader plugin?

http://dpont.pagesperso-orange.fr/plugins/Textures.htm

Remember to turn down ambient to 0%

Dracorat
05-01-2011, 02:18 AM
That works!

It was causing some strange bright spots with "soft" as the parameter to plug, but using "normal" instead worked a charm!

Thank you so much!

Here's the result!

http://gallery.rptools.net/d/69010-1/Church+Top+3.png

XswampyX
05-01-2011, 07:14 AM
Thanks, glad it worked. :thumbsup: