PDA

View Full Version : Soft shadows



Tony3d
04-25-2011, 01:27 PM
Hi, Is there anyway to turn off soft shadows from a spot light? I have an object with an outer shell thats 75% transparent, but I don't want it to cast shadows. If I turn off cast shadows for that object, I still get them because there not raytraced I guess.

wrench
04-25-2011, 01:32 PM
Turn off shadows for the light?

B

Tony3d
04-25-2011, 02:18 PM
Turn off shadows for the light?

B

So I can't just turn off shadows for that one object?

lardbros
04-25-2011, 04:11 PM
By turning them off on the object it will turn the shadows off... not sure what you mean. May be best not to use the lightwave spotlight with shadow-mapped shadows anyway, they don't always cut it these days! Other software has much better shadow mapping options. Try changing to an area light... or spherical. If this doesn't change things, then there must be something else wrong.

Try just changing the spotlight you have there to ray-traced shadows to see if it makes them disappear on the object you've chosen, it may be a limitation of shadow maps in lightwave?

caesar
04-25-2011, 04:33 PM
So I can't just turn off shadows for that one object?

Object properties>render>cast shadows OFF? :D

Spotlight hard shadows Light prop>basic> choose 0 in Soft Edge Angle

Tony3d
04-25-2011, 05:23 PM
The way I see it there is no way to turn off soft shadows using spotlights on a per object basis. Correct me if I'm wrong.

wrench
04-25-2011, 05:26 PM
You're not wrong, but there is always a way. Create another light that only lights your one object and turn off its shadows. The other light(s) in your scene can exclude that one object. You will have some work to do to match up your lighting if it is complex.

B

Tony3d
04-25-2011, 10:34 PM
You're not wrong, but there is always a way. Create another light that only lights your one object and turn off its shadows. The other light(s) in your scene can exclude that one object. You will have some work to do to match up your lighting if it is complex.

B

That will work. Thanks!