PDA

View Full Version : F10 not saving correctly



richdj
04-04-2011, 01:04 PM
Hey everyone. I'm using LW10 on a mac (not sure if that's part of the issue). I've just rendered out an animation, and set the output to .jpg. Hit F10, and it's telling me that the files are not .jpg's, but a 'Unix Executable File'. Thinking I've (initially) made an error, I've gone through and altered the extensions to a few different ones, and still the same with an F10. Saving from an F9 is fine. Anyone any idea's?

Rich

wrench
04-04-2011, 01:29 PM
I guess you mean you rendered out individual frames, rather than a JPG animation (which doesn't exist). Have a look at the files with a hex editor and that way you'll see the starting bytes that usually contain some indication of what file type you chose. You might also try loading the images as Cineon or EXR files since those file types are either side of Jpeg in the choices.

B

richdj
04-04-2011, 10:22 PM
I guess you mean you rendered out individual frames, rather than a JPG animation (which doesn't exist). Have a look at the files with a hex editor and that way you'll see the starting bytes that usually contain some indication of what file type you chose. You might also try loading the images as Cineon or EXR files since those file types are either side of Jpeg in the choices.

B

Yeah, I know jpg is not an animation file. I should have been more specific and said, 'I've just rendered out an animation, and set the output to image sequence in .jpg format.' Not sure what a hex editor is. But, I have tried different extensions and I've added the extensions on in the 'save as' window. Still it just saves it without the extension. It will allow me to rename, adding the extension. But that's not fixing the issue.

Rich

wrench
04-05-2011, 01:39 AM
Changing the extension won't help anyway, since it doesn't change the filetype. Hex fiend seems to be a good enough hex editor to examine the file (http://ridiculousfish.com/hexfiend/) or you could just post one here and I'll have a look for you?

B

jeric_synergy
04-05-2011, 02:26 PM
Yeah, why don't people POST files more??? It'd be 1000x faster to figure things out. Screen grabs too.

BTW, your system isn't set to hide the extensions, is it?

richdj
04-05-2011, 09:16 PM
Yeah, why don't people POST files more??? It'd be 1000x faster to figure things out. Screen grabs too.

BTW, your system isn't set to hide the extensions, is it?

Yes, would be quicker. And yes I think the extensions are set to hide. I'll check when I get home, and try it again.

Rich

richdj
04-08-2011, 12:40 PM
OK, I switched off 'hide extensions' and nothing. I think it's something simple, at least I hope so. See the scenes and objects below. The original, still shows 'Unix Executable File' and the second. A simple box animated. This time it shows the renders as 'documents'. I've added the images as well, so hopefully, if it is just a setting on my mac, it'll show up when you open them...

Original scene (http://www.3dthunder.com/temp/originalBox.zip).

Simple box scene (http://www.3dthunder.com/temp/render_error.zip).

Wrench, sorry to be dim, but I don't understand hexfiend (what it is or how it works).

Thanks in advance...

Rich

wrench
04-08-2011, 02:11 PM
Is the attached image what you are trying to see? Looking at it in the Hex Editor I see that some of the first characters in the file are JFIF. This is a header for a JPEG image, so you have produced JPEGs. I also did a render named anotherbox_BV.jpg for your comparison taken from cctv_02.

wrench
04-08-2011, 02:16 PM
PS. The reason you have no extension on the files is shown in this screenshot. For format you've chosen "Name001". This just saves the file without an extension. If we were still in the Amiga days that wouldn't matter since the Amiga was intelligent enough to read the file headers to determine what type of file it's looking at. Unfortunately Windows, and it seems perhaps the Mac as well have fallen back on accepting what they are told at face value leaving problems like this whose only solution is to use a hex editor yourself and to tell your stupid computer what it should be looking at :rolleyes:

B

richdj
04-08-2011, 02:20 PM
Cheers Wrench.. I'm thinking it's a setting I have on my mac. It allows me to render, and if I manually change the extension (rename the file) once rendered, it'll show up as a jpeg. But, it'll not automatically save it as a .jpg to view after rendering. Hope that makes sense..

Just seen your last post, I'll have a look..

Rich

richdj
04-08-2011, 02:24 PM
PS. The reason you have no extension on the files is shown in this screenshot. For format you've chosen "Name001". This just saves the file without an extension. If we were still in the Amiga days that wouldn't matter since the Amiga was intelligent enough to read the file headers to determine what type of file it's looking at. Unfortunately Windows, and it seems perhaps the Mac as well have fallen back on accepting what they are told at face value leaving problems like this whose only solution is to use a hex editor yourself and to tell your stupid computer what it should be looking at :rolleyes:

B

Your a hero... That's what it was... Can't thank you enough, I thought I was going a little crazy..

Rich

wrench
04-08-2011, 02:41 PM
Hey, I'm not saying you're not - far be it from me to deny anyone their well-deserved portion of madness - but in this case it was purely an incidence of setting up LightWave. It's really annoying you can't simply add the extension on afterwards though. Because Unix files don't usually bother with extensions I guess that's why your Mac assumed you had made a Unix file but if you have Photoshop you should be able to use "Load As..." and pick the filetype you want to load them up and then I guess making an action to save them all out with extensions that work.

B