View Full Version : Surface Thickness - ScreamerNet Bug?

10-02-2003, 12:01 PM
Hi all

I did a search for this question but nothing was found, so . . .

Is it just me or do surfaces that use the surface thickness gradient not render out when using ScreamerNet?

If I render within LW it's fine, over ScreamerNet and the whole surface just isn't there!!!

Is this a known bug? Or am I just missing something here!


10-03-2003, 08:35 PM
Does anyone know then?!!


10-21-2003, 02:27 AM
Does it come up with a plugin not found error message?

10-21-2003, 02:32 AM
I pretty sure it didn't I'll have to check!

10-21-2003, 03:15 AM
I tried adding a gradient to the colour channel and set it to Surface Thickness (have to admit that I have never used the setting before so correct me if I am doing it wrong) and whenever I do a F9 render I get an unexpected quit.

10-21-2003, 03:56 AM
The last time I used it myself, I found LightWave got rather unstable too. That was a while back though, my original question earlier was that if their was an error message saying LWSN can't find the Surface Thickness plugin then it may have something to do with Matt's lwext3.cfg file and if LWSN is looking in the right place for it.

Just a thought.



10-21-2003, 04:30 AM
moth0027 - I loaded the object with the surface thickness gradient in it's surface properties into a brand new scene, and for some reason if 'raytrace shadows' was turned off it crashed, turn it on it was okay! Try it, very odd!

lord I re-scanned my plugins which seems to have sorted the problem, thanks! I could have sworn the plugin config was up to date! I set SN up way after I installed the latest version of LW!


10-22-2003, 01:34 AM
On Mac or PC, Surface Thickness WILL crash LW if you don't have some type of ray-tracing on. Kevin Philips started a thread on this, I was just trying to find it.

'I'll be back'

10-22-2003, 01:43 AM
here it is -


kevman rules

10-22-2003, 03:23 AM
Nice one toby...

the result at the end of that thread you came up with was certainly impressive.

Going to have to give it a try at some point.

01-02-2004, 04:42 PM

I too am having the exact same problem. I'm trying to render a scene of a flooded home. I used the Surface Thickness input parameter to give the flood water a murkey brownish look. When rendered from within Layout it looks perfect; exactly like floodwater. Over Screamernet however the effect seems to be missing. I looked at the output in the LWSN message window on the only machine I was using on the network at the time and didn't notice any plug-in missing messages.

Have you Solved this little problem yet?

BTW, your Screamernet instruction manual is perfect. I followed it to a "T" and everything works perfect (except for the floodwater thing)


01-03-2004, 09:07 AM
Thanks! glad it helped.

I just re-scanned my plugins and re-copied the programs folder to each node and it seemed to work okay, it was very odd as nothing had changed in my SN setup since I installed the latest update of LW.

01-07-2004, 10:02 AM
Okay, I just did a little test.

I set up a scene with a simple box and a ground plane with a surface thickness gradient applied to the box. I then ran this scene through screamernet and it rendered out exactly like it did in Layout. This tells me that the surface thickness parameter works just fine in screamernet.

My problem is that it doesn't work on my one particular scene; the one with the murky floodwater. In addition there are a bunch of tree objects that don't want to render in that scene either when run through screamernet.

Any Ideas?