PDA

View Full Version : Quicktime and Energy Saver



brian.coates
02-28-2011, 03:20 AM
Not sure if this is a Mac-only problem but I'd thought I'd post it here to start with...

I'm currently rendering out an animation scene that includes a TV with an .mov file attached on the colour channel, so the video plays on the screen surface as the camera moves around the scene.

This is not the problem.

The problem is that Quicktime is apparently aware of when a monitor is powered down, because when I left my Mac to render out the scene with the monitor turned off, (not unplugged, just powered down via Energy Saver), the .mov file would stop playing and the TV screen would render out as solid black.

As soon as the monitor powered up again, the TV screen surface would render normally again in the next frame.

I usually don't use a screen saver, but it turns out that the frames will render normally when one is active, so the issue is obviously with Quicktime turning itself 'off' when the monitor is 'off'.

From a software design standpoint this obviously makes sense as a power and system resource saving measure; why would you have a video service running when no video can be displayed.

It's just bloody annoying for people like us who need access to the video data for reasons other than to watch it.

I'm not really looking for a fix BTW, (it's relatively easy to workaround), I just thought I'd point out this issue and see if anyone else has encountered it.

System specs: 2008 Mac Pro - OS 10.6.6 - Lightwave 10 (64 bit / Build 2067)

dsol
03-04-2011, 10:57 AM
Not sure if this is a Mac-only problem but I'd thought I'd post it here to start with...

I'm currently rendering out an animation scene that includes a TV with an .mov file attached on the colour channel, so the video plays on the screen surface as the camera moves around the scene.

This is not the problem.

The problem is that Quicktime is apparently aware of when a monitor is powered down, because when I left my Mac to render out the scene with the monitor turned off, (not unplugged, just powered down via Energy Saver), the .mov file would stop playing and the TV screen would render out as solid black.

As soon as the monitor powered up again, the TV screen surface would render normally again in the next frame.

I usually don't use a screen saver, but it turns out that the frames will render normally when one is active, so the issue is obviously with Quicktime turning itself 'off' when the monitor is 'off'.

From a software design standpoint this obviously makes sense as a power and system resource saving measure; why would you have a video service running when no video can be displayed.

It's just bloody annoying for people like us who need access to the video data for reasons other than to watch it.

I'm not really looking for a fix BTW, (it's relatively easy to workaround), I just thought I'd point out this issue and see if anyone else has encountered it.

System specs: 2008 Mac Pro - OS 10.6.6 - Lightwave 10 (64 bit / Build 2067)

That's extremely bizarre. Can you convert your quicktime to an image sequence (eg. PNG)? I can't believe that Energy Saver turning off a display causes this to happen, but then again I never render using quicktimes as image sources for surfaces.

Are you sure it's actually the display sleep that causes the problem? Try using image sequences. Or if you were using a quicktime codec with your video that uses intra-frame compression, like h264 - try using one that compresses on a per-frame basis (like Photo JPEG)

toby
03-05-2011, 10:12 PM
Rendering with any video file, input or output, isn't a good idea, you should leave video to video editing apps. Nuke started having similar problems as soon as they started supporting video files. Your issue is just one of many possible ones, like codec incompatibility, framerate, interlacing etc.

You might even get faster renders by not forcing lw to run qt at every frame. Using Power saving on a rendering machine is not a good idea either, you could switch off the monitor manually instead.