PDA

View Full Version : Really annoying bug with Output Color Space



Mastoy
02-24-2011, 10:08 AM
Hi everybody

I would like to know if anyone is experiencing the same bug as I am :
Here are the color settings for my Layout

http://www.izipik.com/images/201102/24/jub1xhn1e8thhzt2hq-bug03.jpg (http://www.izipik.com/)

Create a simple scene with a ball, no need to touch anything, render it
Here is what I get

http://www.izipik.com/images/201102/24/iddqy5i1s5uckvwxsh-bug01.jpg (http://www.izipik.com/)

Now open the image in Photoshop or any comp software, boost the contrast and luminosity to very high levels
Here is what I get

http://www.izipik.com/images/201102/24/h3oj5uhfgis1mza6pk-bug02.jpg (http://www.izipik.com/)

If you set the Output Color Space to Linear, the snow disappears.

Am I doing something wrong ?

3DGFXStudios
02-24-2011, 10:11 AM
That supposed to happen. That dithering so its not a bug, its a feature. You can switch it off in the processing tab. It's to remove banding.. But you even do get it in linear space but you have to crank the values up a lot more.

Mastoy
02-24-2011, 10:19 AM
Thx for the answer !
Disabling the dithering does the trick.
The problem is that the snow shows up in Fusion, even without cranking up the luminosity :(
It's barely noticeable, but it's there ...

3DGFXStudios
02-24-2011, 10:30 AM
Yup I know. The only remedy is to turn it off. ;) But it can also be handy if you have lots of gradient stuff in your scene.

Mastoy
06-09-2011, 09:51 AM
Hi it's me again :)
I'm still convinced there's something wrong about dithering ... Just add 4 or 5 layers of renders on top of each other in any comp software and all you get is snow and crap all over the screen.
That 's a little disappointing.

Sensei
06-09-2011, 10:14 AM
Because these background pixels are really 0,0,0 and 1,1,1.. Not solid one black.
1,1,1 multiplied by 255,255,255 (boosting luminosity), will give you the brightest white- what you showed in 3rd picture.

Sensei
06-09-2011, 10:19 AM
When you will run LW v9.6 (so no color space!), and press F9, without any scene (!) and click and hold left mouse button and start moving mouse in rendered image in Image Viewer window, you will see in window title that RGB values are changing, not constant 0%,0%,0% as you might expect.

vfxwizard
06-09-2011, 10:19 AM
Just to be sure: you have disabled dithering in LW and save linear images in a floating point format such as exr? If so there should be no noise at all -except for shading noise, of course.

3DGFXStudios
06-10-2011, 03:29 AM
Hi it's me again :)
I'm still convinced there's something wrong about dithering ... Just add 4 or 5 layers of renders on top of each other in any comp software and all you get is snow and crap all over the screen.
That 's a little disappointing.

In case you are using alpha channels and have nasty stuff there and use eyeon fusion. Did you tick the post-multiply by alpha in the loaders? Or possibly if you have CC nodes in it did you tick pre-divide post-multiply?

Lightwolf
06-10-2011, 03:43 AM
Just to be sure: you have disabled dithering in LW and save linear images in a floating point format such as exr? If so there should be no noise at all -except for shading noise, of course.
Also, noise is only applied to the final RGB in images saved through the render globals.
Buffer savers always save without dithering (as LW applies it afterwards, which makes sense considering that buffer savers are effectively image filters).

Cheers,
Mike

Mastoy
06-10-2011, 04:51 AM
Just to be sure: you have disabled dithering in LW and save linear images in a floating point format such as exr? If so there should be no noise at all -except for shading noise, of course.

Dithering was on :p
I forgot about that problem and rendered a LOT of image sequences ... to finally realize I couldn't use them. That's why I came back here (frustration I guess :cursin:)



In case you are using alpha channels and have nasty stuff there and use eyeon fusion. Did you tick the post-multiply by alpha in the loaders? Or possibly if you have CC nodes in it did you tick pre-divide post-multiply?

Tick the "Post Multiply" was the first thing i did in Fusion, it did solve the noise problem but then all the nice motion blur effects were gone (as expected ... sadly)


Also, noise is only applied to the final RGB in images saved through the render globals.
Buffer savers always save without dithering (as LW applies it afterwards, which makes sense considering that buffer savers are effectively image filters).

Cheers,
Mike

Good to know ! Thx :)

3DGFXStudios
06-10-2011, 05:25 AM
If you want nice motion blur I can give you an other nice tip ;) You can use lw's motion vectors and use them in the native motion vector blur node in fusion to get some really awesome motion blur. You only have to flip the X-vector and feed the stuff into the vector channel using a channel boolean and voila.... :D