PDA

View Full Version : Render Issue (transparency)



therhino5
02-23-2011, 02:58 PM
I'm trying to render a model that has a texture UVd to it. The texture is a PNG and has some transparency, but it always renders the transparent parts white. How can I fix this?

ary3d
02-23-2011, 04:37 PM
I think, if you have a transparent image, it will show you the actual color that you have set up on the material, in your case the standard color is white or lightgrey, what you need to do is clone the texture in the image editor and search for an option "alpha only" you will get the classic black and white alpha image and then you need to copy the color layer to the transparency and change the image with the clone alpha only.

I hope it's help.

Greetings, David

therhino5
02-25-2011, 09:47 AM
Thanks for the help, but I'm not seeing a way to clone the image or an alpha only option in Layout.

Lightwolf
02-25-2011, 09:52 AM
Thanks for the help, but I'm not seeing a way to clone the image or an alpha only option in Layout.
Check the image editor.

Cheers,
Mike

dwburman
02-25-2011, 10:18 AM
I've attached an image that shows the settings in the Image Editor.

Also, you could do this pretty easily in the Node Editor.

therhino5
02-25-2011, 11:27 AM
Thanks guys :)

therhino5
02-25-2011, 12:13 PM
Here's what I've done, what did I mess up in these settings? Thanks for all the help.

therhino5
02-25-2011, 12:29 PM
I'm 99% the problem is that it's rendering the color of the object the UV is placed to, I need it to render the UV, just not that object.

therhino5
02-25-2011, 06:42 PM
I tried the Node Editor method as well, it rendered my objects all black :/

Here is what I had as my settings:

Lightwolf
02-25-2011, 07:48 PM
I tried the Node Editor method as well, it rendered my objects all black :/

Here is what I had as my settings:
Transparency controls the...erm, transparency ;)
Translucency controls how much light the surface picks from the "other" side (i.e. as if the surface was flipped).

Cheers,
Mike

therhino5
02-25-2011, 07:52 PM
I'm a complete idiot, my bad. I thought I did have transparency selected. My bad for not paying close attention.