PDA

View Full Version : Polygons disappear in render!



BenMora3D
02-19-2011, 05:43 PM
I am making a logo and all of the edges are beveled. The VRP looks great but when I render it, all of the beveled edges seem to disappear.
Look at my VPR (top) versus my render (bottom):

http://i80.photobucket.com/albums/j181/BlackOpsBen/vpr.jpg
http://i80.photobucket.com/albums/j181/BlackOpsBen/render.jpg

Exception
02-19-2011, 06:01 PM
Hm, well, that is likely due to a mesh fault.

You can check the normals, but it's more likely to be nonplanar polygons. Look for those in the statistics panel of modeler. How to deal with those depends on the result you want. Tripling is easiest but may be not so smooth. Tripling and MergeTrigonsX after might be nice, although you might end up with the same problem.

Might be something else but I doubt it.

probiner
02-19-2011, 06:14 PM
Do you have N-gons? Non-Planars, can you attach a partial mesh of the object? Those images don't help much since one can't see the mesh, although i guess the mesh consists in quads

Usual reasons for that: http://www.newtek.com/forums/showpost.php?p=1106613&postcount=6

For now i can only say, before trying to triple give Normal Corrector (http://www.lwplugindb.com/Plugin.aspx?id=20e5fbf4) a shot (make backup).
Good Luck

BenMora3D
02-19-2011, 10:00 PM
I checked the mesh and it seems fine. The polys are flat, 4-point, correct normals. hmm. A piece of the model should be attached to this post. Thanks for helping me out!

funk
02-19-2011, 10:30 PM
VPR seems to be more forgiving than the renderer.

The problem is the big front face of the logo. Its a non planar ngon. Go into polygon selection mode, press "w" for polygon stats, click the "+" next to non-planar, then triple them with "shift-t"

Personally Id manually turn it into quads

HolyMonkey-
02-20-2011, 03:26 AM
Hello, this is an offtopic question directed to you mora =)

I like your render and curiouse if you could share your render global setting, light setup and the settings for the black color??

Cheers =)

probiner
02-20-2011, 05:54 AM
Ben you got in there, the biggest and coolest (cool hand) N-Gon i've ever seen :D Unfortunetly it is not planar. But i did not know that these type of issues would propagate to the polygons around, even when they are quads! Strange!

Anyway, since in your case this is supposed to be flat, it's easy to solve, just select the N-Gon and the faceloop that goes around it and flatten them (Stretch tool with 0% vertical factor does the job).

Many times is good to break these type of polygons into smaller and convex ones, when things are not supposed to be flat unlike this particular situation.

Cheers

BenMora3D
02-20-2011, 08:55 AM
Awesome! That was precisely the problem! Thanks Probiner and Funk for looking at my model! I flattened the huge n-gons and it renders perfect now!



...I like your render and curiouse if you could share your render global setting, light setup and the settings for the black color??

Cheers =)

Here's a screen of my settings that I changed for the render:

http://i80.photobucket.com/albums/j181/BlackOpsBen/settings.jpg
Sorry it's a little small.

BenMora3D
02-20-2011, 09:05 AM
Now you can take a look at the whole thing! Not quite finished but thought you might like to see what you helped me with!

http://i80.photobucket.com/albums/j181/BlackOpsBen/logo.jpg

probiner
02-20-2011, 10:52 AM
Ah ahhh cool hand is not alone =)
Glad it worked out.